Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a HP Pavilion G4-1212TU laptop and put Ubuntu 11.10 on it. WiFi works badly. It can usually connect (though showing a lower strength level than when the laptop is in Windows) but sometimes immediately, sometimes after a while, the connection becomes so bad as to be unusable.

That is, the connection strength shows the same number of bars, but TCP/IP requests seem to fail or packets lost.

HP doesn't seem to have any LINUX/Ubuntu drivers for the WiFi for this laptop.

$ lspci -nnk | grep -i net -A2
01:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: Hewlett-Packard Company Device [103c:1795]
    Kernel driver in use: brcmsmac

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
    Subsystem: Hewlett-Packard Company Device [103c:166d]
    Kernel driver in use: r8169
share|improve this question
    
Hi, and welcome to AskUbuntu. Can you update the question with the output of lspci -nnk | grep -i net -A2. The output should provide essential info about the networking hardware. –  mikewhatever Jan 15 '12 at 7:41
    
Yep, thanks. Not really sure what's the problem with the wireless. It seems to be using the right driver, at least according to this: askubuntu.com/questions/12355/… –  mikewhatever Jan 16 '12 at 8:52
    
I'm planning to try connecting to another WiFi other than the one at my house to see. At my office, I only have a wired connection (and the laptop works fine with a wired connection.) –  Ian Jan 17 '12 at 1:44
    
I have tested it with another WiFi and have the same symptoms -- it starts out working, but then after a few minutes, starts dropping the connection. I dread having to switch back to Windows with this machine, but if I cannot get consistent WiFi on it, I guess I'll have to. –  Ian Jan 17 '12 at 14:34
    
I thought I'd try the NDISwrapper option, but the Windows XP driver I downloaded from the HP website is an EXE file, and I'm trying to figure out how to get the INF file out of the EXE file. Archive manage complains that the EXE file "Archive: /home/ianlinux/Downloads/sp55086.exe [/home/ianlinux/Downloads/sp55086.exe] End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive." " –  Ian Jan 19 '12 at 2:34

2 Answers 2

User ts3 over at Ubuntu Forums wrote a solution which worked for me, finally, after so long a struggle. So if you're facing the same problem as me, check it out at http://ubuntuforums.org/showthread.php?t=1889170

Here's his summary:

  1. The b-43 installer does not support BCM4313 (4727)
  2. The bcmwl-kernel-source driver (found in the Ubuntu Software Center) supports it but first one needs to make sure that
    1. b43 and the option to activate the STA Broadcom drivers through System Settings -> Additional Drivers are uninstalled/disabled
    2. that those drivers (b43, bcma, brcsmac) are blacklisted and
    3. that the wl driver that works is NOT blacklisted

See the link for details.

share|improve this answer

In my HP nx 7300 this worked (from terminal):

sudo apt-get purge broadcom-sta-common broadcom-sta-source bcmwl-kernel-source ; sudo apt-get install b43-fwcutter firmware-b43-installer

Maybe you will need reboot. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.