Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few months ago, I needed to mute the left channel, and the easiest way to do it was to use the gnome-volume-control tool. It has stayed muted since.

Since then I've upgraded to Ubuntu 11.10, and the gnome-volume-control tool is nowhere to be found.

I've tried:

  • the default mixer panel
  • alsamixer
  • pavucontrol

None of these work. What can I do?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Sound settings in 11.10

The Volume Control applet should still be there. In Unity it will be found in the top right panel menu Sound Settings. You can also start the application from the command line by running

gnome-control-center sound

Adjust balance

There you will find a slider to adjust sound balance:

enter image description here

Command line

You can also see the channel sound volume settings from the following command

pacmd list-sinks

This will give you (amongst many additional settings) for each sink:

volume: 0:  49% 1:  49%
        0: -18,39 dB 1: -18,39 dB
        balance 0,00
base volume: 100%
             0,00 dB

Changing balance from the command line can not be done with pacmd. We need to do this with ALSA mixer:

amixer sset Master 100%,100%
share|improve this answer
1  
The amixer command did it! –  Gilead Jan 15 '12 at 22:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.