Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tascam US-122L since Windows is really crappy with this, I decided to try linux and ubuntu to be specific..

I tried searching different forums and sites on how to make my US-122L work, but most of the link and site that teaches how to make it work are really out dated.. and I cant get myself to trust a tutorial that is published 2009 and last edited early 2010..

does anyone know how to make my Tascam US122L work? if not just give a link on how to make it work.. atleast from someone who is using and made work on theirs.

share|improve this question

I got mine to show up as an alsa device w/11.10 on a Dell inspiron 1525 (pretty much stock) with the following protocol:

Follow the Mediabunto repository instructions:

Specifically, use this command:

sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

once that's completed execute the following commands:

sudo apt-get update

sudo apt-get upgrade (say yes, this will update your system, may take a bit)

sudo apt-get install alsa-firmware-loaders alsa-firmware

At this point, plug in the US-122 and it should be detected by the system and the drivers loaded.

You know it worked right when you execute:

cat /proc/asound/modules 

and there is a line in there referring to snd_usb_usx2y

however ymmv, i can address this in Jack (and record to Rosegarden fine) but when using alsamixer and selecting the Tascam device, it claims there are no settings available.

share|improve this answer

Sorry, wrong answer.

Answer works for the US-122 but the Question was asked about the US122L. The Model name only differs one Letter but the hardware is NOT the same according the Ardour forum

The suggested installation on that forum also seems to be out dated. At least it does not seem to work for Ubuntu 14.04 64bit machines. 3.13.0-66 (will try another kernel tomorrow) in dmesg I can see it is detected, but in the sound panel the settings are not added. So there is clearly something not right.

On Linux music forum it is suggested to use the Arch Linux kernel

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.