Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Laptop on which wireless and every thing used to work perfectly.Today morning I noticed the suddenly there is no wireless at all. On a working condition I used to have folllowing

lspci -vnn

0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: wl
    Kernel modules: wl, ssb

and

/etc/lsb-release
Ubuntu 11.04 64 bit

Module in use was wl.ko But now all of a sudden it fails to load any module for wireless.I have no idea why this happened.I am a SOHO user who does not have any thing other than web surfing and multimedia to do on this machine.I even booted from a Live USB but still wireless here failed to work (prior to installation same Live USB was able to detect the wifi card and wireless worked with this live USB). The driver in use was found on the LIVE cd at following location

pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu3_amd64.deb

which used to show as additional drivers available for installation.Now this option even does not come when I boot with this Live USB.Since the installation of Ubuntu I have kept this Live USB as a backup. Can some one help here?

share|improve this question
    
This is not a question that can be simply answered. Troubleshooting wireless that used to work usually requires an exchange of posts to gather additional information, which is more suitable for a forum or irc chat. I'd recommend ubuntuforums.org. –  mikewhatever Jan 15 '12 at 7:57
add comment

1 Answer

up vote 3 down vote accepted

Please remove any installed drivers in "Additional drivers". Then reboot your computer and reinstall the driver. Reboot once again and hopefully, your wireless driver will work properly.

share|improve this answer
    
yes this worked like a charm seems 11.04 have a problem in wireless driver I need to put 11.10 on the machine. –  Registered User Jan 15 '12 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.