Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 Unity with activated default theme Ambiance. My problem here is that there are no shadows visible for any window. I tried to enable them using gconf-edit, but that did not work for me.

After googling a little more, I found out, that these Compiz values get overridden or are ignored by Unity. So I tried to edit the file /usr/share/themes/Ambiance/metacity-1/metacity-theme-1.xml, but that did not help either.

Any suggestions are welcome, because my desktop looks rather messy with a few windows open. It's hard to distinguish between windows without visible shadows.

share|improve this question
1  
Are you using Unity2D? Does your graphics hardware support Unity, and do you have any necessary proprietary drivers installed? Window shadows require Compiz, and do not show up in Unity2D. –  Adrian Jan 14 '12 at 20:39
    
No, I am not using Unity 2D. I think my graphics card should handle shadows fine, it's an Intel HD 2000. When using another OS the desktop effects never cause any problems. What I should mention is, that I am running Ubuntu as a virtual machine. But other effects like tranparency or moving windows fast do not cause any problems. Also i checked the "Accelerate 3D graphics" option for this virtual machine (VMware). –  Pratzelwurm Jan 14 '12 at 20:56
add comment

1 Answer 1

I used the Unity-2D Settings tool but got no window shadows. I tried then to find something in the gconf-edit tool that could be the cause.

In the /apps/metacity/general I noticed that the compositing-manager key was on, but the compositing-effects key was off.

Enabling it gave me the shadows!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.