Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried several times to install radio tray on my fresh ubuntu 11.10 installation but when I run ~$ sudo apt-get install radiotraythe following dialog pops up at the end of the script:

Media change: please insert the disc labeled
 'Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)'
in the drive '/cdrom/' and press enter

I've performed previous installations of this app on another computer using the same repository and all went smooth. My Ubuntu Oneiric version was installed from a USB flash drive, so don't understand that request from apt-get.

share|improve this question
up vote 9 down vote accepted

Probably you still have the following option ticked in your Software Sources:

enter image description here

If ticked, Ubuntu will install packages from the installation media rather than downloading from the internet.

share|improve this answer
Thanks a lot, already unticked. Now cannot run apt-get cause it's still waiting for the CD. Not even allows me to kill the process in system monitor. Would a logout do it? – Stbn Jan 14 '12 at 10:27
give it a try or a reboot. Check that the untick value in software sources has been retained. – fossfreedom Jan 14 '12 at 10:39
... also remember to refresh your software sources via update-manager or sudo apt-get update – fossfreedom Jan 14 '12 at 10:42
Tried but didn't work, was wondering if there was other way to stop apt-get from running when this happens without rebooting the system. – Stbn Jan 14 '12 at 10:51
... I find a quick 30 second reboot resolves these issues... – fossfreedom Jan 14 '12 at 10:55

This happened to me on 12.04 (precise).

What got me into this mess in the first place was trying to upgrade from 11.10 to 12.04 by cdrom.

We must be careful here, whereas it's the "Other software" tab that we enable the cdrom on, it's the "Ubuntu software" tab that we need to disable.

Naturally you can also try this:

  1. edit the file /etc/apt/sources.lst -> comment out the lines referring to cdrom by removing the # in front of it
  2. Then execute the command in a terminal sudo apt-get update

but know what you're doing!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.