Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Often, when I boot up my PC, the Ubuntu 11.10 login screen prompts me to enter my login details (as per normal), but after I've done that, it asks me a second time.

To be clear, I log in the first time. The screen goes black. The login screen appears a second time. I log in a second time, and it works.

This happens often enough for me to question it.

share|improve this question
1  
Is this behaviour user specific? Try creating a new user account and log into that. If it still occurs, then its likely to be a graphical issue - what is your graphics card and what drivers are you using? –  fossfreedom Jan 14 '12 at 7:40
    
There is only one user on this PC, and it is me. I am running dual Nvidia GTX 460 cards and I've not had any login bugs with other distros. In fact, that I know of, I've had no graphical hassles at all. I AM, however, running Simple LightDM, so that I can have a consistent desktop wallpaper at login. Not sure if that makes any difference. –  Gonzoza Jan 14 '12 at 8:29
    
give my suggestion a try - you can always delete the user account later. Which nvidia driver have you installed? –  fossfreedom Jan 14 '12 at 8:33
    
Will give it a shot. I am using the driver that was offered to me when I installed 11.10. I had two options; the recommended one and the post-release one. I chose the post-release one, although it seems no different to the recommended one (after trying both). –  Gonzoza Jan 14 '12 at 9:59
    
I do suffer from the same problem. I blame(ed) my windows partition. not off logic or sound reasoning... but because windows was buggy and p'd me off. I will try to find out more about what is causing the issue and post. –  rlemon Feb 9 '12 at 23:44
show 12 more comments

4 Answers

I had the same issue due to some mixup of keyrings.

Go to System / Preferences / Passwords and Encryption Keys.

I had two keyrings there, one called "login" with no keys in it, and another called "default" with several keys, for example the password for my wifi.

  1. Copy the passwords of all the keys in the "default" keyring (for backup)
  2. Delete the default keyring
  3. Logout
  4. Login, and re-enter passwords when asked, for example for your wifi, etc

From this point on your keys and passwords will be stored in the "login" keyring. This keyring is unlocked when you login to Ubuntu, so you only have to enter your password once.

share|improve this answer
add comment

Try removing Plymouth and the restart. And please tell if the problem is resolved or not.

You can refer this link which states that if your password contains number "2" then gnome restarts. Also please tell me if you are using gnome along with Ubuntu .

http://ubuntuforums.org/showthread.php?t=1417140

share|improve this answer
    
I have updated my post. Please try and revert to it. –  Ravi Ranjan Apr 1 '12 at 17:51
    
This comment is unhelpful. "Try removing Plymouth" is like advising someone to fix their car but not telling them how to do it. –  Gonzoza Apr 2 '12 at 5:58
1  
You can remove Plymouth from synaptic. start synaptic package manager > search for Plymouth in quick filter > then click on green button and select "mark for removal" and apply the changes. And its done –  Ravi Ranjan Apr 2 '12 at 16:03
    
@Gonzoza have you tried removing Plymouth or changed your password so that it does not contain number 2. –  Ravi Ranjan Apr 4 '12 at 15:35
    
No I haven't. I've not had this problem in weeks, so I see no reason why I need to tinker with it, for now. –  Gonzoza Apr 4 '12 at 20:03
add comment

Same problem happens to one of the user-accoun ,I resolved it via switching login manager

First I installed kdm and set it as default login manager

sudo apt-get install kdm 
sudo dpkg-reconfigure lightdm

and chose kdm

Then switch back to lightdm if you hate kdm

Now single login is enough

share|improve this answer
add comment

The key quote from the OP as to whether this is still an issue is:

No I haven't. I've not had this problem in weeks, so I see no reason why I need to tinker with it, for now.

To diagnose this types of issues first a simple check is to see if a theme or other configuration causes this issue.

Thus the question:

Is this behaviour user specific? Try creating a new user account and log into that.

If by creating a new user and the issue still occurs then the problem is highly likely to be either a graphical issue and/or a compiz issue.

Both of these issues should be reported as a bug report.

It would be helpful in such a report to looks at posting the contents of /var/log/Xorg.0.log. Often you can see what the issue is by looking for errors in this log.


In conclusion - the OP states this has not occurred for weeks. Its highly likely an update (graphical related or compiz related) has resolved this question.

Case-Closed :)

share|improve this answer
    
It happends to me when i installed vistar theme twise ,it creates a new user to apply changes when i did twise it may created configuration files twise, similar issue happend in 10.04 when I disabled automatic login twise ,i just reinstalled ubuntu for fixing it –  Tachyons Apr 4 '12 at 21:48
add comment

protected by Community Apr 10 '12 at 11:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.