Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install the 64bit AMD64 Mac iso on my Macbook Pro 5,1 and I can only get to the Ubuntu screen which allows you to choose the LiveCD option or the Install Now option (plus some other choices).

Once I select either LiveCD or Install Now, I get a blank screen with a flashing cursor and nothing...the system just hangs.

I do have rEFIT installed and have had earlier versions of Ubuntu working on this laptop. I currently have only OS X Snow Leopard installed and freed up about 80G of space for Ubuntu.

Any suggestions are most appreciated.

share|improve this question
    
I was able to get 10.04 LTS installed. Everything is working. –  mlphoenix Jan 16 '12 at 17:20
add comment

2 Answers 2

The "default" graphics driver in latest (K)Ubuntu live CD(& DVD)'s is Nouveau (more on the Nouveau wiki page). This driver does not function properly along with the Nvidia GT9600M graphic card. The problem is well described in Bugzilla Bug #27501, nVidia 9600M GT (Macbook Pro current model) is unable to boot.

One can workaround this show-stopper by pressing for example the F6 key (which is for to add/alter the kernel boot command line), then immediately press Esc and add nouveau.noaccel=1 as an extra instruction. Read more at X/Troubleshooting/Nouveau. Also valid are the instructions over at the respective wiki page for the Macbook Pro 5,1 and Ubuntu 11.04 Boot/GRUB/Plymouth.

This worked for me today using a Kubuntu 11.10 64-bit live DVD.

share|improve this answer
    
Posting more than 2 links not allowed with a reputation < 10. Will edit links later if and when reputation grows > 10. –  Nikos Alexandris Feb 27 '12 at 15:35
    
Thank you @Lekensteyn for "activating" the links. –  Nikos Alexandris Jun 18 '12 at 12:56
add comment

I have a Macbook 5.1 (with the nvidia 9400 and the 9600GT) wich i boot / and installed in EFI mode, i never used any MAC iso though. Just the standard Ubuntu 64 iso.

what I noticed was that the dual Gfx card setup was messing with the live CDs X. This is also nice because it saves some battery and the laptop is cooler. i found it to be easiest to disable the 9600Gt card in grub before booting into the live cd.

in your grub menu where you can select your kernel , add the following each on a new line

outb 0x728 1

outb 0x710 2

outb 0x740 2

outb 0x740 0

if your screen turns entirely black. Then its managed to disable the wrong card because the order of the cards is reversed. Just reboot into macOS and switch witch card you want to use as your active card and redo the instruction above.

share|improve this answer
    
Your statement in the last paragraph: Is that an assumption/guess? I'm asking because it does help with the problem at all :( –  user24668 May 17 '12 at 18:52
    
nope this is based entirely of my own experience. –  tomodachi May 20 '12 at 13:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.