Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fit PC that essentially runs just a subversion server and as a test server for web applications. I upgraded a while back to 10.04 LTS and no issues. I don't have any keyboard or monitor installed on it, I just access the desktop through VNC, and while a little slow, it works perfectly fine.

Suddenly, today, I'm having an issue accessing Subversion. I tried to VNC to the machine, but it's refusing connections.

I've SSH into the server and reboot, but still no dice. I can manage OK (usually) on my own with the desktop, but I don't use the terminal very often, so I'm kind of stuck now and hoping someone has an idea...

I can confirm that the VNC Server is being started at startup. I run netstat and can see the following:

(Not all processes could be identified, non-owned process info will not be shown, you would have to be root to see it all.)

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:5901            0.0.0.0:*               LISTEN      4261/Xtightvnc  
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      -               
tcp        0      0 0.0.0.0:6000            0.0.0.0:*               LISTEN      -               
tcp        0      0 0.0.0.0:6001            0.0.0.0:*               LISTEN      4261/Xtightvnc  
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      -               
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      -               
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      -               
tcp        0      0 0.0.0.0:60888           0.0.0.0:*               LISTEN      -               
tcp6       0      0 :::80                   :::*                    LISTEN      -               
tcp6       0      0 :::6000                 :::*                    LISTEN      -               
tcp6       0      0 :::22                   :::*                    LISTEN      -               
tcp6       0      0 ::1:631                 :::*                    LISTEN      -               

Which I presume to mean VNC is listening to port 5901.

Don't know what else to do from here. Any help would be appreciated.

share|improve this question

1 Answer 1

OK, so I seem to have resolved this. The Subversion error was indicating a lack of disk space, which made no sense because I couldn't figure out where all the space was going.

Turns out there was a hidden file that was 110GB. The file was .xsession-errors and was FILLED with lines like such:

11/01/2012 07:38:23 AM Authentication deferred - ignoring client message

It had been outputting about 13000+ per SECOND. I cleared the file and rebooted and subversion came back to life as did VNC.

While I haven't solved WHY this happened, I am at least temporarily, able to work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.