Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I tried to create a Desktop quicklist for my gnome-terminal to open byobu with a specific byobu profile.

There's the part of my gnome-terminal.desktop file :

[NetBook_Byobu Shortcut Group]
Name=NetBook Byobu
Exec=gnome-terminal --disable-factory --sm-client-disable --class=netbook_byobu -x BYOBU_WINDOWS=netbook-session byobu 
TargetEnvironment=Unity

But nothing appends when I click on the shortcut. So I tried to launch the exec command.

gnome-terminal open with an error :

There were an error while the creation of the child process for this terminal

The execution of the Child proccess « BYOBU_WINDOWS=netbook-session » failed (no files or folder of that type)

But when I launch byobu with the byobu profile :

$ BYOBU_WINDOWS=netbook-session byobu

The command works perfectly

I don't understand where the problem is. Maybe someone could help me ?

Best Regard, Winael

share|improve this question

1 Answer 1

Try this:

[Desktop Entry]
Name=My Custom Byobu
Comment=Custom Byobu Windows
Icon=byobu
Exec=BYOBU_WINDOWS=netbook-session byobu
Type=Application
Terminal=true
Categories=GNOME;GTK;Utility;
X-GNOME-Gettext-Domain=byobu

This is based on the default byobu desktop file at /usr/share/applications/byobu.desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.