Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I reinstalled PulseAdio beacause I my indicator-sound just disappeared, but it didn't help.

enter image description here

Strangely, I have installed indicator-sound and still don't have that sound control. Nay, I don't even have any settings in "Sound Settings":

enter image description here

I ran "Volume Control PulseAudio" from unity launcher and I got this:

enter image description here

So I ran start-pulseaudio-x11:

$ start-pulseaudio-x11 
Connection failed: Connection refused
pa_context_connect() failed: Connection refused

What Can I do to fix it?

share|improve this question
    
I posted my problem in this thread too: ubuntuforums.org/showthread.php?t=1871144 –  r9s Jan 13 '12 at 18:01
    
if you reset your pulseaudio conf via mv ~/.pulse ~/.pulse_backup , logout and login does your audio stuff reset correctly? –  fossfreedom Jan 13 '12 at 20:24
    
Oh my god! It fix my problem! THANK YOU fossfreedom! –  r9s Jan 14 '12 at 7:57
add comment

2 Answers

up vote 4 down vote accepted

converted comment to answer

Some pulse-audio issues can be resolved by resetting your pulseaudio configuration file then logging out and logging in to regenerate it automatically.

mv ~/.pulse ~/.pulse_backup

From your comment - this is exactly the case for your situation :)

share|improve this answer
add comment

I found out that in the login screen, I could change the volume but it was a session issue.

I typed:

sudo chown -R $USER /home/$USER  

and restarted. Now I have the control.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.