Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Some of the Fn key combinations don't work on my EeePc 1005HAB.

They control important functions such as:
  • volume up, down, and mute
  • sleep
  • launch task manager
  • external monitor toggle
  • WiFi on/off
  • track-pad on/off
  • back-light on/off

The only buttons that do work are the screen brightness up and down. This would be a great little net-book for Ubuntu if only these function keys and track-pad button would work.

Update: I have tried to install eeepc-acpi-scripts from the software center but it wont install and returns an error:

Package dependencies cannot be resolved.

Update: After trying to install eeepc-acpi-scripts to no avail I searched lanchpad and found this bug #262679. In comment #35 fioghual writes:

I don't know if I'm correct, but in my case, after doing some research, it proves unnecessary to install it. What solves everything is:

sudo gedit /etc/default/grub

replace: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

and then: sudo update-grub

After some testing I found that this solution works perfectly on 10.04 but after an upgrade to 10.10 the process must be repeated again. In 10.10 everything works except the track-pad on/off and the back-light on/off. Does anyone know how to fix this? Typing is much more difficult if the track-pad is on.
share|improve this question
    
Just wondering, is it alright to include what I find in my question when I edit it, or should I answer my own question? –  derstreber Oct 26 '10 at 20:22
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Jorge Castro Nov 29 '11 at 1:30
add comment

2 Answers 2

You can try to install eeepc-acpi-scripts Install eeepc-acpi-scripts and see if that helps (after a reboot).

share|improve this answer
    
I've tried that already but I get an error that says: Package dependencies cannot be resolved. –  derstreber Oct 26 '10 at 13:13
    
Found a bug report: bugs.launchpad.net/ubuntu/+source/acpi/+bug/262679 –  derstreber Oct 26 '10 at 19:56
    
More like this: bugs.launchpad.net/ubuntu/+source/linux/+bug/505452 –  JanC Oct 26 '10 at 20:21
add comment

Try with this and this posts on WebUpd8.

share|improve this answer
    
The second Link looks similar to what I found. –  derstreber Oct 26 '10 at 20:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.