Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed pure-ftp server but i had problems logging into it with virtual users. I managed to diagnose the problem: it's the incomplete default parameter specification. This is how the script starts by default at startup:

Starting ftp server: Running: /usr/sbin/pure-ftpd -l pam -u 1000 -8 UTF-8 -E -O clf:/var/log/pure-ftpd/transfer.log -B

but that's not good because -l is not specified. This is the correct form to start it:

pure-ftpd -l puredb:/etc/pure-ftpd/pureftpd.pdb

So, the q is: How to change the startup param definition for pure-ftpd?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Most services allow you to change startup params in /etc/default/NAME. If not, you'll have to edit /etc/init.d/NAME (or /etc/init/NAME.conf for Upstart scripts). Do not forget to restart the service, that's not automatically done for you.

share|improve this answer
    
These are the file that could be found in the dirs, pastebin.com/8Fj2Peya and pastebin.com/2TFZVfpN , but i couldn't find anything useful to change. Could you take a look please? –  alex Jan 13 '12 at 9:32
    
Have a look at /usr/sbin/pure-ftpd-wrapper –  Lekensteyn Jan 13 '12 at 9:58
    
Searched for it but with no results, please have a look too : pastebin.com/LvXv6yfQ –  alex Jan 13 '12 at 13:35
1  
From man pure-ftpd-wrapper: The Pure-FTPd daemon allows to use different authentication methods together. The authentication methods are tried in the order they are specified on the command line. In order to achieve the same flexibility with files in the /etc/pure-ftpd directory, pure-ftpd-wrapper checks all valid symbolic links within the directory /etc/pure-ftpd/auth in alphabetical order. E.g., a link in this directory pointing to /etc/pure-ftpd/conf/PureDB would enable authentication against a PureDB database.; try: sudo ln -s ../conf/PureDB /etc/pure-ftpd/auth/99puredb –  Lekensteyn Jan 13 '12 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.