Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

$ sudo apt-get update
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://extras.ubuntu.com maverick Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192
W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/maverick/Release  
W: Some index files failed to download, they have been ignored, or old ones used instead.

How can I remove these warnings? Running apt-get update has given me these warnings from the beginning of my fresh 10.10 install.

share|improve this question

marked as duplicate by David Foerster, Eric Carvalho, andrew.46, Pilot6, Videonauth Jul 4 at 13:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 11 down vote accepted

Option 1

From here:

sudo apt-get install --reinstall ubuntu-extras-keyring

Option 2

See here.

Summary:

Open the terminal and run the following commands:

gpg --keyserver keyserver.ubuntu.com --recv 3E5C1192
gpg --export --armor 3E5C1192 | sudo apt-key add -
sudo apt-get update
share|improve this answer
    
This is more concise: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 16126D3A3E5C1192 – Gin Gordon Jul 17 at 9:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.