Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old machine with a max. resolution of 1024x768 and I have a problem setting screen resolution from current (640x480 too big icons and words) to max .

I tried the following :

  1. Installing nvidia driver (nothing happens)

  2. Editing xorg.conf manually twice

    1. adding a subsection with a mode "1024x768" (nothing happens)
    2. adding a subsection with virtual 1024x1768 from ubuntu help ( only displays a part of the screen)
  3. using xrandr (nothing happens)

  4. using nvidia -xconfig ( it actually did nothing)

  5. deleting xorg.conf ( this gave me a 800x600 shifted screen a bit to the left ) but then i ran the nvidia-xconfig and the resolution returned the same .

here is my xorg ( doesn't seem to be generated by nvidia tool)

Section "Screen"
    Identifier "Configured Screen Device"
    DefaultDepth 24
EndSection
Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
EndSection‏ 
share|improve this question
    
It might be useful to know what graphics card you have; if it's old it's probably not supported by the nvidia driver and then you would need the nouveau, nv or vesa driver (depending on how old it is). –  JanC Oct 26 '10 at 2:02
    
Yes it's old , Geforce FX 5200 –  Ahmed Oct 26 '10 at 2:24

3 Answers 3

up vote 1 down vote accepted

Well , I finally fixed the issue by completely removing ubuntu 9.10 and installing ubuntu 10.10 from scratch and I didn't install Nvidia driver . Ubuntu 10 recognized my best resolution itself and everything worked fine .

share|improve this answer

I'm coming to the conclusion that external binary drivers from a graphics card vendor ARE EVIL INCARNATE. On three separate desktop PC's over the past two years;

A) 12yr old 1GHz pentiumII 256MB ram bog standard desktop with 10+yr old graphics card

B) 2yr old 1.6GHz celeron 1.2GB ram with onboard video

C) 1yr old 3.3GHz AMD 2GB ram with onboard video

D) latest Intel 3.3GHz i5-2500K 2GB ram with new reputable brand-name 256MB video card

all possible permutaitons of A), B), C), D) with the following three monitors

aa) 3rd hand CRT capable of 1024x768 (Packard-Bell, dodgy EIDID codes list worst mode first)

bb) simple flatscreen capable of 1024x768 (Hansol H711)

cc) new wide flatscreen capable of 1920x1080 (BENQ)

All of these combinations are less frequently able to detect the monitor and available screen resolutions after installing 3rd party drivers. The list of available defaults gets truncated and the system loses its ability to use the native resolutions which are best for each respective monitor.

On fresh installs of various versions of Ubuntu including 7.10, 8.04, 9.10, 10.04 and 10.10 I've had the same behaviour every time - don't install 3rd party graphics drivers unless you need transparency effects; rely only on linux defaults, and it ends up with the best resolution of the monitor for workstation use by the end of the week. For some reason the available modes are not always listed in >Display> gui nor in xorg.conf but occasionally they are and once found they work. After installing proprietary drivers, fancy screen effects become enabled but it forgets the most useful screen resolutions at every reboot and cannot read the monitor type. I suspect that the 3rd party driver hogs the reply from the find monitors EDID or something like that rather than making it available to be applied. After much searching I'm still usually stuck with a downgraded screen resolution, always about 70% of the best available from the particular screen plugged in. How can it choose which downgraded screenmode to offer the poor unsuspecting user without knowing something about the screen it is plugged into? 800x600 if plugged into a 1024x768 last year and offered 1024x768 if plugged into a 1920x1080. Therefore it could seem that the proprietary driver is using information to f about with users instead of putting that information to best good use. If I were a weak willed puppet in the dungeon of lost computer users I'd pay for a different operating system on the grounds of it being worth paying the professionals to sort out the hardware drivers. As it is, I smell an extortion racket and when I smell that smell I usually flush twice and use bleach just to make sure.

PS If the 1995 operating system had not shipped on a broken installation disk I'd be playing some of my favorite games on it at high resolution and super fast frame rate.

share|improve this answer

Your monitor is not recognised properly. I also have an FX5200 and it works fine, because I have an expensive CRT monitor (Hansol 720D). You have to set up a monitor with 1024x768 in xorg.

share|improve this answer
    
I tried that and It didn't work . –  Ahmed Oct 28 '10 at 0:26
    
Next time the problem shows up try to put another real (hardware) monitor in the vga port and see if it works. Maybe it will fix the first monitor problem too. –  iugamarian Oct 28 '10 at 22:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.