Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

After minimizing the Google Chrome window, clicking on the chrome icon in the unity sidebar doesn't restore the window. Additionally, the the icon seems to behave more like a launcher: no white indicators showing whether a window is open or not, and clicking on the icon just opens another instance of chrome. No other icon does this.

Can anyone help me here?

share|improve this question

marked as duplicate by Mitch Apr 27 at 7:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
have you installed the chrome by SOFTWARE CENTER or by downloading from the google.com ? –  VENKI Jan 13 '12 at 3:19
1  
if you want to view them just press "super(windows)+w" –  VENKI Jan 13 '12 at 3:20
    
Software center only had Chromium, not Chrome, and I did download the .deb file from the official website. and @VENKI, viewing the windows aren't really a problem. I just want the icon to do what it's supposed to. –  TreefrogInc Jan 13 '12 at 3:21
    
have you tried to install from the .deb file? –  VENKI Jan 13 '12 at 3:27
add comment

4 Answers 4

up vote 2 down vote accepted

Works fine here - the launcher icon for goggle-chrome launches & controls google-chrome plus the 2 quicklists options.

Maybe try resetting - Remove the icon from the launcher if pinned, then do a log out/in.

While you shouldn't need to, try adding back to launcher this way - Browse in nautilus to /opt/google/chrome. Inside you'll see 'goggle-chrome.desktop'. Grab it with your cursor and DnD onto the unity launcher, then see if it works as intended.

This fixed the issue for me with 64 bit Ubuntu 12.04: simply launching "chrome" from the dash didn't work, I had to use the nautilus method described above.

share|improve this answer
    
Thank you for your answer! Apparently, I neglected to look elsewhere on the site first for answers, and there is another question that deals with the same problem here. Thank you for your time anyway! –  TreefrogInc Jan 13 '12 at 23:34
add comment

This happens if this setting in chrome is wrong, set Preferences >> Personal Stuff >> toggle: "Use system title bar and borders"

Google Chrome unity icon does not restore after minimizing

share|improve this answer
add comment

I am really sorry to inform this that the chrome you installed from the software center was broken so please uninstall the chrome, and install it by downloading from google.

share|improve this answer
    
This is the exact site I downloaded from. I don't see how it can be broken. –  TreefrogInc Jan 13 '12 at 3:48
    
have you got all back to normal –  VENKI Jan 13 '12 at 3:51
    
Look; I did not install from the Ubuntu Software Center. The site you linked me to is the same site I used to download the .deb package the first time. The icon still does not work after re-installing. –  TreefrogInc Jan 13 '12 at 3:56
    
the above case is reverse is reverse sorry –  VENKI Jan 13 '12 at 3:59
    
the CHROMIUM and chrome are same do not get wrong idea by the name and then uninstall the one you installed and reinstall from the software center –  VENKI Jan 13 '12 at 4:00
show 3 more comments

Disable all the extensions and close the browser. Try again and enable the extensions one by one.

That works for me.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.