Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I just bought a new COMPAQ Presario CQ57-356SA laptop, and I'm having problems enabling the wireless. When I start the laptop the Wi-Fi icon glows orange (off), when Windows boots up somewhere during the splash screen it goes blue (on).

However, Natty doesn't recognize my wireless driver at all saying "ath0 - no wireless extension".

Wireless works fine on 11.10, but I don't really like and and would rather stick with gtk2.

The wireless driver is called Ralink RT5390.

I've tried loading kernel 3 onto Natty, but that didn't resolve my problem.

Any help would be appreciated.

share|improve this question
    
How did you install Ubuntu? If you installed it to the hard drive, have you connected to the Internet by cable so it can download updates and drivers - including wireless adapter drivers? If you are running Ubuntu from a live CD (or DVD), it won't download the drivers because it has no place to put them. –  Kelley Jan 13 '12 at 2:43
    
Yes, I've installed Ubuntu on hard disk, but the additional drives menu wouldnt show wifi drivers anyhow. Anyways I've solved the issue when I've found a tutorial on compiling your own drivers. I'm typing from android, will post the link when will come home, so it gets archived here, in case there are other people with same issue. –  Koffeehaus Jan 14 '12 at 19:39

1 Answer 1

up vote 1 down vote accepted

Okay, I've found the answer at this page:

https://atinfinity.wordpress.com/2011/05/21/ralink-rt5390-wi-fi-driver-on-ubuntu-11-04/

Since the openSUSE driver patches have been updated, the package version numbers of the commands must be changed as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.