Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to kernel 3.2 last night. Now:

  • Gnome 3 resets to default after reboot and/or log out.
  • Cannot change theme, font, etc through gnome tweak tool.
    • cannot add any keyboard shortcuts that carryover across reboots.
  • Mouse freezes after reboot. Have to run synaptics trackpad manually twice from the applications lens before it starts but has default settings.

Same with unity.Created new user. Same problem.

Selected old kernel from boot. Problem persists. No changes to UI are present after logout or reset.

In essence, any changes made to ubuntu get reset on reboot. As if I am running a live cd. Every time I boot up, i have the same settings as whatever came out of the box.

Is this a user rights issue? Some file(s) cannot be overwritten because of insufficient privileges (i am admin on this machine)

Edit: Tried gnome-settings-daemon in terminal

  $ gnome-settings-daemon

  Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1597:20: Invalid animation description
  GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be       saved or shared with other applications.

  ** WARNING **: You can only run one xsettings manager at a time; exiting

  ** WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

  ** WARNING **: Name taken or bus went away - shutting down

Two Xsetting managers? How do I get rid of one of them? What is the other one?

Kindly help (ubuntu noob)

share|improve this question
    
Is gnome-settings-daemon in your startup applications? –  Tigull Jan 12 '12 at 22:42
    
how do I do that? I added "gnome-settings-daemon" to the start up applications list (it wasn't there before) made some changes & rebooted. Changes got reset again. –  Mohamed Waqqas Jan 12 '12 at 22:58
    
Have you tried just executing it from the terminal? That trick worked for me, so it seems your problem's something else, but unfortunately I wouldn't know how to help you further. I'm confident someone will help you out. –  Tigull Jan 12 '12 at 23:10
    
@Tigull just tried it. Here is the out put: [~$ gnome-settings-daemon GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.] Hopefully help is on the way. Thanks for your input though :) –  Mohamed Waqqas Jan 12 '12 at 23:15
    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Mar 26 '12 at 19:38

1 Answer 1

I had the exact same problem.

Inspecting apt-get, it indicated that some packages were held back.

Doing a sudo apt-get dist-upgrade and logging out and back in solved the issue, and all my settings were restored.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.