Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use PowerBroker LikeWise 6.1 on Ubuntu LTS 10.04.3 to join to my AD domain. I've done this in the past before LikeWise was owned by PowerBroker & I can get it to work "pretty well". However, each time I try to install this version, it breaks my network connection. I'm not sure why or where to look to fix it. Any suggestions on where to look? I've checked some of the usual network config files Likewise modifies:

  • /etc/resolv.conf
  • /etc/hosts
  • /etc/nsswitch.conf

They all seem to be OK with respect to the network I'm on. ifconfig shows inet6 for eth0 but not inet (it should show inet)

eth0 Link encap:Ethernet HWaddr 00:0c:29:1c:75:be
inet6 addr: fe80::20c:29ff:fe1c:75be/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:3159 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:255179 (255.1 KB) TX bytes:936 (936.0 B)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The problem turned out to be that Apparmor doesn't like the additional stuff Likewise adds to /etc/apparmor.d/sbin.dhclient3 file. Only solution I've been able to find is disabling Apparmor for dhclient3:

# ln -s /etc/apparmor.d/sbin.dhclient3 /etc/apparmor.d/disable/

then

# apparmor_parser -R /etc/apparmor.d/sbin.dhclient3
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.