Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I also posted this on Ubuntu Forums and apart from a guy who tried to help nothing came of it. So i though i'd try posting here...

So, after a restart yesterday, my computer doesn't boot correctly... After GRUB, it prints

mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target Filesystem doesn't have /sbin/init.
No init found. Try passing init=bootarg.

BusyBox v1.10.2 (Ubuntu 1:1.10.2-2ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.

and falls to the busybox prompt...

I booted a 10.10 live cd.

Here is the output of fdisk -l for /dev/sda

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e45d1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        8924    71681998+  83  Linux
/dev/sda2            8925        9179     2048287+  82  Linux swap / Solaris
/dev/sda3   *        9180       46149   296961525    7  HPFS/NTFS
/dev/sda4           46150       60801   117692190    7  HPFS/NTFS

sda1 is the root filesystem (Ubuntu 10.04)

sda2 is the swap

sda3 is a Win7 NTFS partition

sda4 is an NTFS partition with media files.

I can normally access sda2-4.

The problem is when i try

sudo e2fsck /dev/sda1

with any switch it prints:

ubuntu@ubuntu:~$ sudo e2fsck /dev/sda1
e2fsck 1.41.12 (17-May-2010)
e2fsck: Device or resource busy while trying to open /dev/sda1
Filesystem mounted or opened exclusively by another program?

When i try to mount the disk, the console just hangs.(it doesn't become unresponsive, the cursor just goes to the next line and doesn't do anything else) I tried leaving it for about 15 minutes in case it was checking the disk but nothing happened.

I don't care about restoring the system (i was gonna reformat anyway), all I want is access the data so i can backup.

share|improve this question
Look in /var/log/kern.log or in the output of the dmesg command for anything concerning sda (especially read errors). Also try sudo lsof +f -- /dev/sda1, which may tell you what is using /dev/sda1. If you see any interesting output, especially if you don't know what sense to make of it, add it to your question. – Gilles Oct 27 '10 at 23:00

if you just want to pull the data from a damaged drive before trying to recover the drive usability via reformat, booting from a livecd of some sort is really the best option. there's lots of good distros for doing so. SystemRescueCD is probably the foremost of these and i've used it several times with great success

share|improve this answer

Perhaps some daemon running on the Live CD is trying to access the partition. That daemon may be hanging indefinitely, just like the mount command that you tried, leaving you with the "device busy" message. You seem to be comfortable with the command line. Find a bare-bones console-only CD that won't run any pesky daemons, and try again with that. The Ubuntu alternative install CD may be a good choice.

share|improve this answer
the alternate install CD is not a good option for that at all O.o - you cannot use it to run a command line, it's for installing. – RolandiXor Oct 28 '10 at 18:13
I thought it provided command lines on the extra terminals. – Ryan Thompson Oct 28 '10 at 21:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.