Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The Unity launcher on my system has display issues, all the icons are scrunched up under the menu bar. I've restarted my machine, logged into the GNOME session and back into unity, and triple checked the settings in CCSM, but it just stays broken.

It appears to be a display issue, if I right click on the "unused" grey parts of the launcher bar it brings up the context menu for the applications in the correct places, but it just refuses to display them anywhere but mostly hidden under the menu bar.

This is obviously quite irritating. ;)

Here's a screenshot demonstrating the problem:

Annoying Unity Launcher Behaviour

share|improve this question
I had this same problem and it was so irritating. So my dad (works with computers) restored it to the backup from yesterday, but that didn't end up helping at all. We googled it and came to this page, and he finished updated that weren't opening or showing and then i just restarted the computer and it worked! Yay! – user68421 Jun 5 '12 at 1:20
up vote 3 down vote accepted

I had the same thing happen recently. I installed all of the updates available and rebooted, and that fixed the problem. I suspect that the updates also overwrote some of the configuration changes I made using gconf-editor, and I'm now having to go back and redo them.

share|improve this answer
There were some outstanding updates for compiz, so I did those, and re-logged in. Issue still oustanding. I'll test a full restart in a while, see if that makes any difference. – unit3 Jan 12 '12 at 22:53
A reboot fixed this, even though logging out and logging back in didn't. No idea what state Unity keeps around when you're still logged out, but apparently it was something! Thanks for the advice! – unit3 Jan 13 '12 at 17:37

Never saw that before, but first thing i would done is to

compiz --replace


share|improve this answer
I tried both of those, nothing. Still broken. – unit3 Jan 12 '12 at 20:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.