Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I set my account to be allowed to log in without a password. I only wanted this temporarily, but I can't seem to change it back to how it was before.

How can I make it so that my password is required to log in? I'm not talking about auto-login; at the login prompt I can just hit Enter to log into the system.

When I go into the User Account settings, I do have a password set and the auto-login switch turned off.

share|improve this question

4 Answers 4

Go to:

System Settings | User Accounts

Double click on User Account. Then select your user and double click.

click Unlock in the upper right hand corner. (you will need to put in your password if you have one).

Ensure your account has a password. Ensure that Automatic Login is turned off for your account.

enter image description here

share|improve this answer
Thanks for your suggestion. I tried this, but no luck! I still have the login button on the login screen instead of a password box. –  Alex Jan 13 '12 at 0:41

It sounds like you've set up an empty-password login. If you set a password on the account, using the passwd command in a terminal window, you'll be fixed.

share|improve this answer
Thanks for your help. I tried this, but it did not seem to change anything. It still does not require a password to log in. –  Alex Jan 13 '12 at 0:42

Remove the user from nopasswdlogin group

sudo gpasswd -d <USERNAME> nopasswdlogin

please refer to the following link

share|improve this answer
That worked for me! Thanks a lot. –  Hiura Jun 26 at 11:43

I found a solution, but it was quite a work around!

Opening up the Settings -> User Accounts and then setting a password does not work.

However, creating a new administrator account, then logging in with the new account, and then setting a password for the original account seems to do the trick.

I hope that's clear for anyone who experiences the same issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.