Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have developed a project in asp.net which contains javascript functionality as well. The application is working as expected in windows with all the browsers. But I am facing issues with linux OS. Wherever the javascript has been added, that functionality will not work. I am not receiving any error as well. Kindly help me as soon as possible to sort this out as this is very urgent.

Thank you.

share|improve this question
1  
Is the webpage publicly available, so that we can test it as well? –  user unknown Jan 12 '12 at 9:50
    
Try opening the Error Console (Tools -> Web Developer -> Error Console). Are there any relevant errors reported for the pages you are having trouble with? –  James Henstridge Jan 12 '12 at 10:21
add comment

2 Answers

First make sure you have enabled Javascript in Firefox. You can check that setting in one of following ways:

A. From Firefox menu go to :

Edit > Preferences > Select "Content" tab

Default (and preferable) settings would be

enter image description here

B. Using about:config

Enter about:config in address bar and then type javascript in the filter section. The preference name "javascript.enabled" should have true as its value. If you are not clear look at following screenshot.

enter image description here

If you have above-mentioned settings as they are (i.e. in their default configuration), make sure you have NOT enable any script blocking Add-ons (like "No Script") to Firefox.

share|improve this answer
1  
[OPTIONAL] You can install Firebug Add-on to see whether there are any errors while delivering web pages. –  nobody Jan 12 '12 at 10:58
add comment

Did you check the options of firefox? I have a localized, german menu, so I can't tell you the original names - maybe it is a bit different:

In the 2nd menu, last entry 'settings', a dialog pops up. The 3rd section 'content' shows some option boxes, among them 'enable javascript'. Is it checked?

Another approach: In the addressbar, enter

about:config

confirm, and in the searchbox below enter

 javascript

What does it say? Something suspicious?

share|improve this answer
    
Ya its checked and have enabled pop-up also. –  Chaitra Jan 12 '12 at 9:46
    
I will check and get back to you. Thank you. –  Chaitra Jan 12 '12 at 9:55
    
I checked this and still its not working. –  Chaitra Jan 12 '12 at 9:58
1  
@JacobJohanEdwards: Having Javascript disabled can be the reason for Javascript not working, so while it isn't the answer to Chaitra's problem, it might be for other ones, which find the question, searching for a similar problem. –  user unknown Jan 12 '12 at 10:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.