Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgrade to 11.10 (from 11.04). Waited a couple of months to get a "safer" version.

Unity comes by default - ok.

Since I cannot stand Unity, being an old-time Ubuntu user and having a few applets / shortcuts on the top bar (like cpu,mem monitoring, start a bunch of apps...), I did

 apt-get install gnome-session-fallback

and chose Ubuntu Classic in the login menu. Works.

But... the top bar is now almost empty, all my icons disappeared, no more monitoring... Not mentioning the admin menus ...

How can I recover all the icons and menus from my before-upgrade era?

edit

And also, where can I find the system monitoring applets for Gnome 3? (the 11.04 gnome 2 ones do not work anymore)

share|improve this question
add comment

1 Answer 1

You have to press alt (or super+alt) to access the right-click menu and to move applets. Otherwise, Gnome Panel 3 is mostly identical, but it has been upgraded to GTK3 and other Gnome 3 technologies. This means that applets also have to be upgraded, and there might be some that haven't been upgraded yet.

You'll probably want to get the indicator-applet-complete package from https://launchpad.net/indicator-applet.

share|improve this answer
    
Sorry but... move from where? Do you mean recreate one by one? This is what I want to avoid. Some applets may have been obsoleted - but I want to recover also all the icons / shortcuts which I created either manually or using the "Add to panel" option. Is there a tip like a cp .gnome?/something/files .newgnome?/somethingelse that would make these icons appear on the top panel, as it used to be the case in 10.04? –  ring0 Jan 12 '12 at 10:16
    
The configuration system has changed in Gnome 3, so you would have to convert the settings, or recreate them. I don't know if there are any scripts to automate it. You can still use the "Add to panel" function. You just press and hold the alt key and right click the panel. For some reason I don't know, you sometimes have to use super+alt instead of just alt. –  Jo-Erlend Schinstad Jan 12 '12 at 21:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.