Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to change the default orange cone icon for the VLC media player on the Unity bar in 11.10. I have tried following similar posts in this forum, but without any luck. I changed the vlc.png icon I found in the /usr/share/icons/hicolor/256x256/apps directory (which i assume is the icon used on the unity bar) by copying a different .png file to it with the same name. It is also a 256x256 pixel .png file. I restarted Ubuntu and the orange cone is still there. I've read tidbits online about having to recompile the program or something, so I don't know if this is more complicated a process than I assumed. I'd also like to be able to do this for other programs, but this one specifically (for now at least). I'd greatly appreciate any suggestions! Thanks!

  • I updated my icon cache and the vlc icon is changed in dash, but not when I place it on the unity bar. I've noticed that certain applications have icons stored in different directories and I'm wondering if I'm missing something. I tried out a new icon for google chrome and that one worked, but VLC won't.

  • Well I tried placing an icon in 128x128 and that didn't work either. Is it possible the icon is some how hardcoded into the program? I've also now succesfully changed firefox's icon as well...so I don't think I'm doing something wrong

share|improve this question
    
You seem to havereplaced the wrong file.. you're not using Hi-color, check which icon theme you're using and go to it's directory, then check for a vlc icon most icon themes have one if it doesn't have one, check the index.theme file in gedit and see from where does it inherit the icon. –  Uri Herrera Jan 12 '12 at 4:33
    
You are correct! I placed it in the hicolor folder because that is what I read on another post, and didn't think about it. Though there is no vlc.png icon in the ubuntu-mono-dark folder (which is the theme I'm using). It says it inherits from Humanity dark, gnome, and hicolor. I changed the one in hicolor, which is the only one with the icon, and i did what Pomme Verte said, but it only changed the icon in dash and when i dragged it to the unity bar it reverts to the old icon. –  BretD Jan 12 '12 at 7:30
add comment

2 Answers

up vote 3 down vote accepted

If it isn't an issue with the theme you're using, then have you tried updating the icon cache with sudo gtk-update-icon-cache /usr/share/icons/hicolor ? (replace "hicolor" by whichever theme you're using. You'll need to put the icon in the appropriate theme folder as well)

As a bit of extra information. In /usr/share/applications you'll find a vlc.desktop file. You could change the following line:

Icon=vlc

With another Icon of your choice (I prefere to set a svg file in the "scalable" directory rather than a rasterized x by y png ). After that you have to do the update command I gave earlier.

If you encounter any issues with the update command try appending the -f -t options.

share|improve this answer
    
Well this almost worked! I updated the icon cache and if I search for vlc in dash, the new icon appears, but when I drag it to the unity bar it changes back to the standard orange cone. I'm also not using the hicolor theme (I should have realized this). I'm using the ubuntu-mono-dark icon theme, but there is no vlc icon in that folder, so I'm not sure what to do. –  BretD Jan 12 '12 at 7:24
1  
@BretD Perhaps the icon you set up is the wrong size? It works for the dash but not the bar so it bounces back to a default VLC icon (either in the correct size or in "scalable"). I will admit always using .svg files in the scalable directory so I haven't encountered this yet. –  D.Mill Jan 12 '12 at 7:31
    
@BretD I'm reading that the default size for icons in the launcher are 48x48 . Maybe try putting your icon in that folder if scalable isn't an option. (And at the correct size obviously) –  D.Mill Jan 12 '12 at 7:35
    
hmmm...well it is the right size according to the properties, but maybe I'll try an svg file. Thank you very much for your help! –  BretD Jan 12 '12 at 7:36
    
I tried this method for google chrome using a .png and it worked perfectly! I'm thinking there is just an issue with the VLC program. In the /usr/share/vlc folder there is a vlc.ico file which won't open, and I'm not exactly sure if that is perhaps the icon being used?? but thank you again for your help –  BretD Jan 12 '12 at 8:05
add comment

You can't change it for now as long as VLC team has not gotten rid of the systray icon hardcoding. Actually it is reported as bug : https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/530797

Pleace mark the bug as affecting you if so.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.