Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to open a file (such as an .odt, or .doc) from say, the Dash or the Firefox Downloads, Ubuntu 11.10 opens Nautilus to the the folder where the file is, rather than just going to the application and loading the file straight away.

In previous releases, when I clicked on a downloaded file, it just went straight to LibreOffice, and it was fine. This is adding a superfluous step in the process.

How do I associate the correct extensions?

share|improve this question

There is an easier way to fix this, even with exo installed (I use unity AND xfce4-panel so I needed both).

Open ~/.local/share/applications/mimeapps.list in an editor (make a backup just in case!). Remove the following lines:


Save, and it should work now.

Some users will need to make exactly the same changes to /usr/share/xubuntu/applications/defaults.list as well. The lines can be commented out by adding # at the beginning of each. The fix works after logging in again.

share|improve this answer
I liked this one and use it. Because exo is needed by some xubuntu stuff. +1 – Anwar Shah Jan 18 '13 at 13:41

uninstall exo

...HOWEVER I believe this breaks xfce, so this will not work if you're using xfce as well as gnome. if you don't need xfce this works. in my case the following packages plus their dependencies:

Completely removed the following packages:

very annoying problem and I had a very hard time finding the answer. finally found this : - if you're looking for a better solution that has more explanation.

I believe this happened when I installed xfce to try it out.

share|improve this answer
Thanks Alex. As it turned out, I just did a complete re-install (there were other problems emerging anyway). But hopefully your suggestion helps somebody else in the future. :) I think you're right though - I'd installed xfce, and the problem emerged after that. I just hadn't seen the connection. – Pepe Lebuntu Jan 17 '12 at 23:20

Similar question. Try this solution which is there in below URL.

Can't open .xlsx file with LibreOffice

share|improve this answer
Not quite. It's not that it's opening the file with the wrong program. It's that it's opening nautilus first as the WAY to THEN open the file. When I click-to-open a word/odt file, I just want to cut out the Nautilus "middle-man", and just go straight to LibreOffice. Going into the "Properties>Open_With" won't fix that. – Pepe Lebuntu Jan 12 '12 at 7:00
i had also faced the same problem.but once manually opened now its worked fine – Deepak Rajput Jan 12 '12 at 7:02
Can you define "manually opened" for me? If I click at the .odt or .doc in Nautilus, yeah, it works great. But if I try to open via the Dash or Firefox, it doesn't. I just checked opening a doc from the "Saved Files" part of Thunderbird, and yep, it does it there too. – Pepe Lebuntu Jan 12 '12 at 10:46

I had the same problem, yet libexo was never installed. The rather brutal way of deleting the .local folder in my home directory solved it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.