Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed a dual boot windows7 /ubuntu 11.10 and the internet is much slower than windows. I have read the post here and tried the solutions presented and none have worked.

Here is what I am dealing with; In Windows my internet is as normal, nice and fast. enter image description here

However in ubuntu on my new system my internet is super slow (Here it is important to note that my other system ubuntu has the same speeds as windows on this system). I have installed all of the updates and am using the latest stable google chrome and my speedtest results are way lower. (upload times out and eventually fails, however before that happens ping is 10ms and download is <5meg). the difference is really felt when downloading anything, including updates.

My system specs are as follows:

 Motherboard: Asus P8Z68-V LX
 CPU:         Intel i5 2500k
 RAM:         Corsair vengeance blue 8GB (4X4GB)
 SSD:         OCZ Vertex 3 60gb

I am using the onboard lan. Drivers were installed from the CD provided with the motherboard. I installed the drivers in Windows (windows was installed first). Ubuntu did not require me to install any new drivers for the internet to work (and by work I mean I can get a connection, albeit intermittent and slow).

I have read people having difficulties with the UEFI BIOS but never internet speeds. Any help diagnosing my problem would be greatly appreciated.

rdl@rdl-home-ubuntu:~$ ethtool -s eth0 speed 1000 duplex full autoneg off
Cannot set new settings: Operation not permitted
  not setting speed
  not setting duplex
  not setting autoneg
rdl@rdl-home-ubuntu:~$ ifconfig eth0 |grep errors
          RX packets:14632 errors:0 dropped:14632 overruns:0 frame:14632
          TX packets:14094 errors:0 dropped:297 overruns:0 carrier:0

running the first command as sudo only changes Operation not permitted to Invalid argument

Here is the output of sudo ethtool eth0

Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
                                         1000baseT/Full 
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

and after I run sudo ethtool -s eth0 speed 100 duplex full autoneg off

Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supports auto-negotiation: Yes
    Advertised link modes:  Not reported
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: off
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

Problem still persists.

share|improve this question
3  
You should probably post the networking hardware specs, just in case. –  mikewhatever Jan 12 '12 at 5:37
2  
are you by any chance using a realtek GigE NIC. If this is the case, then i will point you to this link. dedoimedo.com/computers/kubuntu-realtek.html –  tinhed Jan 12 '12 at 6:26
2  
From the ASUS site, this motherboardis using a RTL8111 chip. This has known problems with Ubuntu. Please check this question: askubuntu.com/questions/16755/…. If it's your problem, please leave a comment here so that we can close this question as a duplicate. –  Javier Rivera Jan 12 '12 at 8:15
1  
I do not receive any errors (other than the occasional timeout), however when I get home tonight I will try out some of the solutions mentioned in that question. –  rlemon Jan 12 '12 at 13:17
1  
@rlemon If your issue is fixed, please let us know how. thanks. –  its_me Jan 12 '12 at 14:41
show 3 more comments

5 Answers 5

up vote 8 down vote accepted
+100

Most probably you need to install the driver from here: http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

The package comes with an install script.

As others have mentioned this is a known issue, try searching for "Realtek RTL8111".

share|improve this answer
    
This did it! here are my new speedtest results –  rlemon Jan 17 '12 at 21:23
    
I should mention upload is a bit slower.. but I was also mucking around with other settings (which I will now revert) –  rlemon Jan 17 '12 at 21:23
add comment

Have you checked the basics

You are connected in 100 or 1000 in FULL DUPLEX ?

If you are running in half duplex, this is the problem

user@server:~$ sudo ethtool eth0
Settings for eth0:
    Supported ports: [ MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: external
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Link detected: yes

To change it (if your card support 1000, look at the Supported link modes line)

sudo ethtool -s eth0 speed 1000 duplex full autoneg off

Do you have network errors ?

user@server:~$ ifconfig eth0 |grep errors
          RX packets:1725783 errors:1 dropped:0 overruns:0 frame:1
          TX packets:1205465 errors:0 dropped:0 overruns:0 carrier:0
share|improve this answer
    
I have updated my question with some more information. Thank you for your answer! –  rlemon Jan 16 '12 at 23:22
    
I have updated also my answer, you have an invalid argument trying to set the speed and duplex because you didn't check what your nic can do, look at the Supported link modes lines in the output of : sudo ethtool eth0 –  jflaflamme Jan 17 '12 at 10:05
1  
You have a lot of dropped frames, i think forcing the right duplex speed and disabling autoneg will help you. Be sure to look into thoses counters increases when you try different config. (But normally, autonegociation for speed and duplex is working well). So basically, check the output of ethtool, and force one of the supported speed in duplex full and autoneg off –  jflaflamme Jan 17 '12 at 10:08
    
after making the alteration noted in my OP the output is now RX packets:31090 errors:0 dropped:31090 overruns:0 frame:31090 –  rlemon Jan 17 '12 at 20:41
1  
no, they are good questions and should be answered for historical purposes. –  rlemon Jan 18 '12 at 15:59
show 3 more comments

It could be an issue of IPv6 implementation for wifi adapter you have. I had very slow internet connection with my Asus K52F, so I had to follow these recommendations: Resolve slow connexion...

share|improve this answer
1  
the suggested solutions in the blog post did not work. –  rlemon Jan 16 '12 at 1:10
    
There is a possible dependance on WiFi chipset. Othewise, your problem has a different nature :) –  Vincenzo Jan 17 '12 at 1:12
add comment

Before you try all these complicated solutions that they are recommending, try this (it's easy because it involves the gui...no commands, easily undone). Also, just a note: I tried a lot of stuff from online solutions people put forth (terminal commands disabling ipv6, installing some driver, doing gedits of things I had no clue what I was doing), but this is the only thing that had an immediate & lasting effect. The others seemingly did nothing; however, it could be that all the other solutions plus the following were what caused this to work (or it could be just this is the solution by itself). I'm a linux newbie, so I don't know.

  • Click on the symbol for your wireless connection (upper right)
  • click edit connections
  • Click on the wireless tab
  • Click on your current wireless connection
  • Click edit
  • Click on ipv4 settings method drop down box: select "automatic (dhcp) addresses only"
  • In the dns servers field: type the ip address of your wireless router or default gateway. Mine was 192.168.0.1 for example.
  • (optional) If you can some how do a benchmark of dns servers, finding the fastest one for you, that would be good. In my results the two fastest were my modem's ip address & my wireless router's ip address. The wireless router seemed to work the best. I did the benchmark in a windows virtual box pc. I tried 4.2.2.6 or .5 but it just remained slow as molasses.

Hit save. Disable your wireless hardware for a few seconds (my method is function key f2), turn it back on and test your browser's speed.

If that doesn't work, click on the ipv6 settings and select method:ignore, hit save & do the same thing (disable wireless, re-enable)

I figured out that there was nothing wrong with the wireless/internet itself because only browsers were slow at going to websites (chrome, firefox, etc) while running them from Ubuntu. But when I tried my virtual box machines, they were lightening fast on the internet.

share|improve this answer
add comment

1. First method :

  1. You need to disactivate IPv6, to do that, open terminal and enter the following commands:

    echo “#disable ipv6″ | sudo tee -a /etc/sysctl.conf
    
    echo “net.ipv6.conf.all.disable_ipv6 = 1″ | sudo tee -a /etc/sysctl.conf
    
    echo “net.ipv6.conf.default.disable_ipv6 = 1″ | sudo tee -a /etc/sysctl.conf
    
    echo “net.ipv6.conf.lo.disable_ipv6 = 1″ | sudo tee -a /etc/sysctl.conf
    
  2. Then restart your system.

If you still have the issue, follow also instructions on step 2.

2. Second method:

  1. A second solution for this issue can be by using the following :
  2. Open terminal and enter the following command:

    sudo -s
    
  3. then gksu gedit /etc/modprobe.d/ath9k.conf and at the end of the file add this:

    options ath9k nohwcrypt=1
    
  4. Save an restart your OS.
share|improve this answer
    
can you please offer more explination to your second method. what exactly am I doing here. –  rlemon Jan 15 '12 at 21:19
    
neither suggestion worked. –  rlemon Jan 16 '12 at 1:10
    
Can you explain why to restart the system? –  user unknown Jan 16 '12 at 1:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.