Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu 11.10 and never touched linux until today. I installed Ubuntu alongside with Windows 7. I have an issue with my laptop overheating and freezing when it uses the high performance GPU graphics mode (hybrid card). It is an easy fix for Windows 7. I simply set the graphics mode manually to the low performance integrated graphics (save power) mode using advanced power settings.

In Ubuntu, I'm stumped at how to do this. When using Ubuntu, my laptop is showing the same symptoms as it did without the fix for Windows. I have the nVidia graphics driver installed for Windows which allows me to see which mode I am in. I downloaded it off of my laptop's website (ASUS). They do not offer driver downloads for linux.

Screenshot of power settings in Windows 7

share|improve this question
    
What laptop model do you have? If the product page reports "Optimus" or "switchable graphics", please submit your machine information following the instructions on bugs.launchpad.net/lpbugreporter/+bug/752542 –  Lekensteyn Jan 12 '12 at 9:22

1 Answer 1

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get install nvidia-current
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

Then reboot and it should automatically use your low-performance graphic chip. To start an application with the nVidia high-performance graphics card use optirun.

Example: Press Alt+F2 then type optirun firefox to start firefox with enabled high performance GPU graphics mode.

Source: [German] http://wiki.ubuntuusers.de/Grafikkarten/Nvidia/Nvidia_Optimus

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.