Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the ubuntu-desktop (apt-get install ubuntu-desktop) but it does not show the GUI and it is not changing. It installed without any problem and I don't know why it does not work.

I select this on the logon screen:

Ubuntu, with Linux 3.0.0-12-generic-pa

and I used this version.

share|improve this question
    
what do you mean by "not changing"? - please describe exactly what is happening when you reboot. What happens if you run sudo service lightdm restart –  fossfreedom Jan 11 '12 at 22:33
    
At the logon screen, did you select "Ubuntu" as your desktop enviroment? If so and it doesn't work, or if it doesn't appear in the list, then we can't really help you without more information. For example, what version of Ubuntu were you running before installing Ubuntu-Desktop (Kubuntu/Xubuntu/Lubuntu, etc.). What logon screen are you using? What version of Ubuntu or Ubuntu derivative are you running? That should be a good starting point. –  William Jan 11 '12 at 22:38
    
When I reboot my ubuntu server dont have gui. –  Tofiq Ahmad Jan 11 '12 at 22:39
    
Do you at least see the LightDM login screen, or are you only given a terminal? –  Christopher Kyle Horton Jan 11 '12 at 23:30
    
Dont see the LightDM ligin screen.only given a terminal. –  Tofiq Ahmad Jan 14 '12 at 20:42

4 Answers 4

As some other commenters already noted, it seems that your X is not running. So you have different choices to make:

  1. Boot your computer.
  2. Login at the prompt. You can use your username and password like at the graphical login.
  3. Now there are different ways to go:
    1. Just type startx at the prompt. After some seconds the graphical screen will appear. You can use it like you are used to. After you log out, you will see the old prompt again. Also after your next reboot the system will show you the non-graphic prompt.
    2. You can also run sudo service lightdm start. After some seconds you'll see the login window of lightdm. Login as you are used to. Like at the above mentioned solution at the next boot there will be no graphic window.
    3. Edit the file /etc/init/rc-sysinit.conf and make sure there is a 2 at the line env DEFAULT_RUNLEVEL=2. Save the file and either reboot or choose one of the above mentioned options.

With the last option your system should boot into graphical mode at every time.

share|improve this answer
    
typing startx did the trick for me. –  noob Jul 16 '13 at 11:41

It sounds as if the x server is not starting and you are being left at the command prompt. If the system is expecting a command line (terminal) login, log in. Then enter startx and see what happens: if it is obvious the system demands admin privileges, enter sudo startx.

I have no experience of Lightdm but if it behaves like gdm then it would run startx as part of its routine, so it might be instructive to try entering lightdm rather than startx before trying to start x manually as above. You shouldn't break your system trying out those two commands.

If I can find the notes I made when last I installed a GUI on a server -I installed gdm, though- then I'll get back to you.

In the meantime, good luck!

share|improve this answer

An answer to this question can be used from here 71621

you can edit /etc/init/rc-sysinit.conf and change the following line:

env DEFAULT_RUNLEVEL=2

share|improve this answer

I would try sudo apt-get install ubuntu-desktop, or [desktop environment of your choice].

ubuntu-desktopInstall ubuntu-desktop

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.