Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed new firefox, however flash doesn't work. When I visit for example YouTube.com instead of vids I see info: please update Your flash player. I am trying to use apturl package for Ubuntu but it gets me a message that: this file cannot be opened because "apt" is not recognized by any program.

How to solve this issue?

Thanks and regards, Misery

PS.: ubuntu 10.04 LTS x64 flashplugin-nonfree or any other flash package don't solve the problem

Below I wrote what finally helped :]

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I know the problem. Have you tried yet if this solution works for you?
No flash on Firefox 8

Flash Aid did the trick here, I guess new versions of Firefox don't like old versions of Ubuntu :p

share|improve this answer
    
It doesn't work. As before I still get a message that flash should be updated –  Misery Jan 11 '12 at 14:27
    
Does it show up in the Plugins screen of Firefox? If yes, is it greyed out? If also yes, what note is beneath it? –  RobinJ Jan 11 '12 at 20:12
    
It helped finally. Description is below :) –  Misery Jan 12 '12 at 8:52

Finally I found out the reason why it didn't work.

First of all one has to download 64 bit version of Firefox which is not on the download website (so it has to be found somehow). Installed it as usual:

tar xjf firefox..bla..bla..x64
sudo mv firefox /opt
sudo ln -s /opt/firefox/firefox /usr/bin/firefox

and run firefox by writing in terminal:

/opt/firefox/firefox

than I have installed flash aid add-on and it did the rest: installed stable flash plugin.

share|improve this answer

flash plugin also produced issues on my 10.04 x86_64 system.The soultion might be to purge all installed flash verions and install from this ppa:

deb http://archive.canonical.com/ubuntu lucid partner
deb-src http://archive.canonical.com/ubuntu lucid partner

After that update your package information and install the following package:

adobe-flashplugin

If you understand german you can also read the background on this german website (where I got it from): ubuntusers.de

share|improve this answer
    
No command 'deb' found, did you mean:... –  Misery Jan 11 '12 at 14:37
    
I guess I'll handle without flash. Anyways it's just linux :] It's normal taht nomal stuff doesn't work and ultra specific stuff works normally :p –  Misery Jan 11 '12 at 14:38
    
You re unfair now... with windows you have similar problems - the only problem with linux is, that hardware and software vendors dont care for linux users. And if you regard that, the support Linux contributers offer without support form those big companies, then it is great! –  Michael K Jan 12 '12 at 8:22
    
I know, that problems with drivers under linux are the fault of hardware producers. :] But chill out, I am using Ubuntu at work and I am very satisfied. However I use only LTS versions and half year after its release. I haven't told that Linux developers did anything wrong, I just said that it is normal that all the unusual stuff like scientific tools and libs etc work like gold under linux, but there are some problems with usual stuff. But anyways... we have VirtualBox to run windows if needed, and finally it solves the problem at last, when all workarounds fail. Regards. –  Misery Jan 12 '12 at 8:43
    
Maybe just dont give up that fast. deb is not a command,rather those lines are ppa-information which you should just add tpo your ppa list, e.g. using software center, sth like "Add software package source" and then install the package I mentioned.Also the package "flashplugin-installer" could do the trick.It is a little tricky because flash isnt open source... –  Michael K Jan 12 '12 at 9:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.