Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

after Purchasing some Music on the U1 Music Store the files were synced from u1 to the computer where I purchased the Albums (Ubuntu 11.04).

On a different machine (Ubuntu 11.10) only some Tracks are synced and showing up the rest is not there. u1sdtool --current-transfers Was listing some of the missing files. After watching this process for a long (very long) time the downloads finally finished and disappeared from the current-tranfers list.

But when i go to ~/.ubuntuone/Purchased From Ubuntu On/Artist/Album the directory is present but empty. Why the is u1 downloading half of a day and then not showing the files? Is there any temporary place where the files are stored before copying them to their target location?

Any Suggestions what could be the Problem?

share|improve this question
I tried several tips I found throughout the internet. Nothing worked. Is there a way to reset the ubuntu one client? Delete all configs, caches etc ... – Axel Jan 11 '12 at 21:27
Deleting ~/.config/ubuntuone and ~/.local/share/ubuntuone should get all configs, settings, etc. cleared. – Nathan Dyer Jan 15 '12 at 17:15
up vote 1 down vote accepted

As Suggested by Nathan Dyer I tried deleting the suggested config which did not work well. I did some further research and found the following thread:

Thread Posting on

I followed steps 1 to 6 described there but modified the actions a bit.

  1. Remove the Computer via the Ubuntu One Client
  2. Quit Ubuntu One
  3. Run u1sdtool -q && killall ubuntuone-syncdaemon
  4. Remove ubuntu one stetting and cache as suggested by Nathan Dyer

    rm -rf ~/.local/share/ubuntuone ~/.cache/ubuntuone ~/.config/ubuntuone
  5. Remove/Rename ubuntu on folder

    mv ~/Ubuntu\ One ~/old.u1
  6. Remove all other folders that were synced with u1 including .ubuntuone

    rm -fr ~/.ubuntuone
  7. Open Unity Dash and find the "Passwords and Encryption Keys" application. Go to the Passwords tab, delete all Couch DB and Ubuntu One tokens

  8. Open the Ubuntu One client again and re-register the computer for sync

After going through all this U1 synced everything from scratch and it finally solved ma issues. I guess step 7 (removing all tokens) did the trick.

I hope this might help someone having the same problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.