Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I used Ubuntu 10.10, my tvtime worked perfectly. After upgrading to Ubuntu 11.10, it only shows "no signal". I've searched throughout the internet for a whole day and couldn't fix it. I also use Windows XP at the same time and it works.

Here is my specification.

  • Ubuntu 11.10.
  • Pinnacle PCTV Hybrid Pro PCI 310i (Philips saa7134)
  • tvtime 1.0.2-6ubuntu1 (I downgraded from 1.0.2-7ubuntu1, default by Ubuntu 10.10)

I'm in Germany which means: PAL/PAL-BG and Frequency table=europe

Here is for the information:

$ lspci
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
01:01.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
04:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series]
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdfcf8000 irq 43
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xdfffc000 irq 44
 2 [SAA7134        ]: SAA7134 - SAA7134
                      saa7133[0] at 0xdfdff800 irq 21
$ xawtv -hwscan
This is xawtv-3.95.dfsg.1, running on Linux/i686 (3.0.0-14-generic)
looking for available devices
port 143-146
    type : Xvideo, image scaler
    name : ATI Radeon AVIVO Video

/dev/video0: OK                         [ -device /dev/video0 ]
    type : v4l2
    name : Pinnacle PCTV 310i
    flags: overlay capture tuner
$ dmesg | grep saa
[    4.484856] saa7130/34: v4l2 driver version 0.2.16 loaded
[    4.484918] saa7134 0000:01:01.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[    4.484924] saa7133[0]: found at 0000:01:01.0, rev: 209, irq: 21, latency: 64, mmio: 0xdfdff800
[    4.484931] saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 310i [card=101,insmod option]
...
[    4.889137] saa7133[0]: registered device video0 [v4l2]
[    4.889169] saa7133[0]: registered device vbi0
[    4.889199] saa7133[0]: registered device radio0
[    4.933671] saa7134 ALSA driver for DMA sound loaded
[    4.933836] saa7133[0]/alsa: saa7133[0] at 0xdfdff800 irq 21 registered as card -2
[    4.980908] DVB: registering new adapter (saa7133[0])
$ dmesg | grep tuner
[    4.730294] i2c-core: driver [tuner] using legacy suspend method
[    4.730298] i2c-core: driver [tuner] using legacy resume method
[    4.824208] tuner 0-004b: Tuner -1 found with type(s) Radio TV.
[    4.856615] tuner-simple 0-004b: creating new instance
[    4.856620] tuner-simple 0-004b: type set to 61 (Tena TNF9533-D/IF/TNF9533-B/DF)

So my card=101 and tuner=61, then tried to use rmmod and load it back with modprobe and it still shows "no signal".

$ modprobe saa7134 card=101 tuner=61

And if I run tvtime with verbose setting, it will show:

$ sudo tvtime -v
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/winnuayi/.tvtime/tvtime.xml
cpuinfo: CPU Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz, family 6, model 15, stepping 13.
cpuinfo: CPU measured at 2200.051MHz.
xcommon: Display :0.0, vendor The X.Org Foundation, vendor release 11004000
xfullscreen: Using XINERAMA for dual-head information.
xfullscreen: Pixels are square.
xfullscreen: Number of displays is 2.
xfullscreen: Head 0 at 0,0 with size 1680x1050.
xfullscreen: Head 1 at 1680,0 with size 1680x1050.
xcommon: Have XTest, will use it to ping the screensaver.
xcommon: Pixel aspect ratio 1:1.
xcommon: Pixel aspect ratio 1:1.
xcommon: Window manager is Metacity and is EWMH compliant.
xcommon: You are using metacity.  Disabling aspect ratio hints
xcommon: since most deployed versions of metacity are still broken.
xcommon: Using EWMH state fullscreen property.
xcommon: Using EWMH state above property.
xcommon: Using EWMH state below property.
xcommon: Pixel aspect ratio 1:1.
xcommon: Displaying in a 768x576 window inside 768x576 space.
xvoutput: Using XVIDEO adaptor 143: ATI Radeon AVIVO Video.
speedycode: Using MMXEXT optimized functions.
station: Reading stationlist from /home/winnuayi/.tvtime/stationlist.xml
videoinput: Using video4linux2 driver 'saa7134', card 'Pinnacle PCTV 310i' (bus PCI:0000:01:01.0).
videoinput: Version is 528, capabilities 5010015.
videoinput: Maximum input width: 720 pixels.
tvtime: Sampling input at 720 pixels per scanline.
xcommon: Pixel aspect ratio 1:1.
xcommon: Displaying in a 768x576 window inside 768x576 space.
xcommon: Received a map, marking window as visible (59).
xcommon: Pixel aspect ratio 1:1.
xcommon: Displaying in a 768x576 window inside 768x576 space.

Using $ scantv -C/dev/vbi0, no signal could be detected.

Everything looks fine. alsamixer is also fine. I don't know where the problem is. I'll appreciate anyone who can show some hints. :)

share|improve this question

1 Answer 1

Using alsa and adjusting the sound device designation and application call in the below script should work for you. After DAYS of frustration I found it on a forum post on forums.ubuntu.com. Unfortunately I seem to have lost the URL and can't give credit where it is due and for that, I am sorry.

I can't say it will absolutely work for you but it should.

Change {hw:3,0} to properly reflect your card and tvtime to your application of choice if you use something else. Copy the text starting with #!/bin/sh

to the end of this post, paste it into a new text file. Save the file. Right click on the file, select properties, go to the permissions tab and make sure it's marked as executable. Run the script and select run if you're prompted.

BTW: still working on trying to fix the audio being slightly out of sync. :)

#!/bin/sh
arecord -D hw:3,0 -r 32000 -c 2 -f S16_LE | aplay -Dplug:surround51 & tvtime -M;
wait 1 tvtime
killall arecord;
killall aplay;
killall tvtime  
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.