Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a mustek 1248 UB scanner and Ubuntu would recognize it but not scan from it, simple scan would tell me that it is unable to connect to the scanner and xsane would tell me

failed to open device invalid argument gt68xx:libusb:002:007

I tried chmod but nothing happened.

share|improve this question
    
scanimage -L gives me "device `gt68xx:libusb:004:017' is a Mustek ScanExpress 1248 UB flatbed scannerb" –  Ahmed Nematallah Jan 11 '12 at 11:11
1  
The AU way is to open a new question for the printer (and make this one solely about the scanner) ;) –  Rinzwind Jan 11 '12 at 11:15
    
also check dmesg for error messages (probably something like dmesg | grep usbfs) –  Rinzwind Jan 11 '12 at 11:18
    
@AhmedNematallah Please ask a new question for the printer –  Jorge Castro Jan 15 '12 at 19:00

2 Answers 2

The scanning part seems to have been solved:

cd /usr/share/sane/gt68xx/
sudo wget http://www.meier-geinitz.de/sane/gt68xx-backend/firmware/SBSfw.usb
sudo chmod a+r *

There are multiple sources for this but they all seem to be based on this thread.

The printer should be supported out the box but multiple people seem to be having problems with this particular model. I suggest you file a bug on the HPLIP site.

Edit: Some people suggest that downloading/installing the latest version of hplip might help but those posts are quite old. The current Ubuntu-version of hplip should be more than new enough.

share|improve this answer
    
thanks a lot xsane worked but the scanner thing didn't move and all it gave me was a wrong image –  Ahmed Nematallah Jan 11 '12 at 11:27
1  
Thanks now the scanner worked, what i did is copy the PS1Gfw.usb from the CD and then rename it to the file you made me download, put it in that folder and xsane worked, now it's just the printer –  Ahmed Nematallah Jan 11 '12 at 11:30

Easy way to enable Mustek 1248 UB scanner on Ubuntu 12.10:

sudo apt-get install xsane
sudo mkdir /usr/share/sane/gt68xx/
cd /usr/share/sane/gt68xx/
sudo wget http://www.meier-geinitz.de/sane/gt68xx-backend/firmware/SBSfw.usb
sudo chmod a+r *

And that's it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.