Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a .Xmodmap file and added the following:

keycode  66 = Tab ISO_Left_Tab Tab ISO_Left_Tab
keycode  23 = Caps_Lock NoSymbol Caps_Lock

df So now my Caps Lock key works as a Tab but the Caps Lock still turning on and off (the CAPS light also turns on and off).

How can do it so that the CAPS don't turn on and off each time I press the Caps Lock Key which now works as a Tab?


I realized that it is only the light that turns on and off. Anyway, how to disable it?

(If that's something impossible to accomplish I guess I'll just have to cover it with a sticker).

share|improve this question
Unless someone else has a suggestion, cover with a sticker sounds good ;P – bodhi.zazen Jan 11 '12 at 19:33
@bodhi.zazen Then I should change this question to: "Which ubuntu sticker do you recommend to cover the Caps Lock light?" – janoChen Jan 12 '12 at 2:36
hahahaha !!! This one : – bodhi.zazen Jan 12 '12 at 2:47
@bodhi.zazen Nice one! – janoChen Jan 12 '12 at 6:04
up vote 2 down vote accepted

Try keytouch to remap the keyboard. Worked with my Logitech Access sound controls and Internet/mail access buttons.

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.