Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ uname -a
Linux ubuntu1110 3.0.0-14-generic-pae #23-Ubuntu SMP Mon Nov 21 22:07:10 UTC 2011 i686 i686 i386 GNU/Linux

laptop model: Lenovo W520

upon trying to enable bluetooth, the led turns on but, bluetooth is fails to get enabled in the preferences also seen below error message in dmesg

[78183.389048] usb 1-1.4: new full speed USB device number 19 using ehci_hcd
[78183.504129] bluetooth: Unknown symbol security_sk_clone (err 0)
[78183.505084] bluetooth: Unknown symbol security_sk_clone (err 0)
[78183.505189] bluetooth: Unknown symbol security_sk_clone (err 0)
[78183.505294] bluetooth: Unknown symbol security_sk_clone (err 0)
share|improve this question

1 Answer 1

My collegue just had this same issue on an Asus laptop after installing linux-backports-modules-cw-3.1-3.0.0-14-generic because his Bluetooth audio device would not connect (timeout). What solved the issue for him is installing the 3.2 kernel from Precise:

If you need to build out-of-tree modules (e.g. nvidia driver), you need to install two additional packages

  • Go to http://packages.ubuntu.com/precise/linux-headers-generic
  • Follow the link to the *-generic package
  • Choose a download on the amd64 or i386 page (open this in a new tab or window)
  • Follow the link to the linux-headers-* package
  • Choose a download on the amd64 or i386 page
  • Install both .deb packages

There is obviously a better way to do this, but this works for now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.