Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to install UltraStar Deluxe in Ubuntu 11.10. On the project homepage and in this PPA there are some packages, but they seem to be for an older release of Ubuntu, because when I try to install them, I get complaints about missing dependencies (packages that are no longer available in the 11.10 repositories):

...
dpkg: dependency problems prevent configuration of ultrastar-deluxe:
 ultrastar-deluxe depends on libavcodec52 (>= 4:0.6-1~) | libavcodec-extra-52 (>= 4:0.6-1~); however:
  Package libavcodec52 is not installed.
  Package libavcodec-extra-52 is not installed.
 ultrastar-deluxe depends on libavformat52 (>= 4:0.6-1~) | libavformat-extra-52 (>= 4:0.6-1~); however:
  Package libavformat52 is not installed.
  Package libavformat-extra-52 is not installed.
 ultrastar-deluxe depends on libavutil50 (>= 4:0.6-1~) | libavutil-extra-50 (>= 4:0.6-1~); however:
  Package libavutil50 is not installed.
  Package libavutil-extra-50 is not installed.
 ultrastar-deluxe depends on libprojectm2; however:
  Package libprojectm2 is not installed.
 ultrastar-deluxe depends on libswscale0 (>= 4:0.6-1~) | libswscale-extra-0 (>= 4:0.6-1~); however:
  Package libswscale0 is not installed.
  Package libswscale-extra-0 is not installed.
dpkg: error processing ultrastar-deluxe (--install):
 dependency problems - leaving unconfigured
...

Apart from compiling the program myself and/or repackaging the software, is there a way I can install UltraStar Deluxe in Ubuntu 11.10?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's no optimal solution, but you can manually install the dependencies by grabbing the needed packages from Launchpad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.