Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm building a HTPC with this ASRock E350M1/USB3 motherboard. The onboard ATI Radeon HD 6310 graphics had a hard time swallowing a 1080p x264 mkv (~10 GB) so I popped in a discrete Nvidia GT 240 (1024MB). Oddly enough, that also wouldn't play it properly.

Both cards had the associated vendor drivers installed and active, I have tried x264 and raw blu-ray to no avail. I know the GT 240 is capable of playing 1080p movies, so what is the hangup?


Choppy refers to getting about one frame every few seconds, but I also see this from time to time: http://ptpimg.me/8yt8ev.png


Output from running vlc from the command line on a untouched Blu-ray (m2ts) rip.

me@GAMMA ~ $ vlc
VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x8d41914] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Warning: call to srand(1326832540)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:2617): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 0
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 0
libdvbpsi error (PSI decoder): TS discontinuity (received 3, expected 0) for PID 256
libdvbpsi error (PSI decoder): TS discontinuity (received 3, expected 0) for PID 256
[0x8ddc6e4] signals interface error: signal 17 overriden (0x3b114c0)
[0x8ddc6e4] signals interface error:  /usr/lib/libQtCore.so.4(?)[(nil)]
[0x8ddc6e4] signals interface error: signal 17 overriden (0x3b114c0)
[0x8ddc6e4] signals interface error:  /usr/lib/libQtCore.so.4(?)[(nil)]

Output from vlc -vvv on the same file: Here


OK, so we got the GT 240 working by using VD-PAU which is a magical thing that tells software like nplayer to use the GPU to do the work instead of the CPU. Problem is that VD-PAU is essentially Nvidia only and the built in graphics are ATI based.

(in ~/.mplayer/config)
vo=vdpau,xv
vc=ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau

I've done some digging and it seems VA-API and XVBA are the ATI equivalents. The question now is how do I get these to work in natty (preferentially with something like xbmc)


So far, with just the onboard Radeon HD 6310 graphics I've done this:

sudo apt-get install xvba-va-driver libva-glx1 vainfo
mplayer -vo xv -framedrop -ao sdl /path/to/000000.m2ts

and it is certainly getting close. Still too many dropped frames to be considered watchable however.

share|improve this question
    
What version of Ubuntu are you using? What programs have you tried to use to play the videos? –  user6658 Jan 11 '12 at 1:41
    
I'm currently in Mint 11 (12 has Gnome 3 which has issues with fglrx) which is based on Ubuntu Natty (11.04). I have tried the ATI card in mint and 11.04, however I've only tried the Nvidia card in mint 11. I've tried mplayer and VLC –  Huckle Jan 11 '12 at 3:42
    
lspci -nn -v : pastebin.com/0sYCEhh8 --- xorg.conf: pastebin.com/6mp9s6S8 --- @Chauncellor –  Huckle Jan 11 '12 at 3:46
    
Choppy playback like you get hangs, or is the image distorted/laggy/ghosting/tearing? –  htorque Jan 14 '12 at 17:14
3  
Can you confirm hardware assisted decoding is actually being used at all? the output from mplayer and vlc (if run in a console) would help confirm or deny this if you coula add it to your original question. Try this in ~/.mplayer/config to turn it on: vo=vdpau,xv and vc=ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, each on their own line. –  Caesium Jan 14 '12 at 17:30

2 Answers 2

up vote 4 down vote accepted
+25

Can you confirm if hardware assisted decoding is actually being used at all?

The output from mplayer and vlc (if run in a console) would help confirm or deny this if you could add it to your original question.

Try this in ~/.mplayer/config to turn it on:

vo=vdpau,xv
vc=ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau
share|improve this answer
    
+1 for persistent helping, I think he deserves the bounty. I also have problems with ATI drivers, so my next video card will definitely be Nvidia. ATI is just not friendly enough with the open community to share the code to make good drivers. –  bioShark Jan 21 '12 at 0:18

Try to install SmPlayer and go to options, preferences, then on general tab, on output controlers, select gl(fast). Then on performance tab, on decoding threads, select to 8. I did that for my ATI HD 5470 that was playing very bad and got fixed. Tell-me something about how it performs.

share|improve this answer
    
I ran it with both 8 threads and 2 threads (since this is a dual core machine w/o hyperthreading) with no avail, so I tested again (both thread levels) on each of: xv, xv(0 - ATi Radeon AVIVO), gl(fast), gl (fast - ATI cards), gl2. Some did better than others but none performed as well as mplayer from the command line with these options -ao sdl -framedrop -vo xv –  Huckle Jan 18 '12 at 4:11
    
did you tryied to download the driver on the ati website? support.amd.com/us/gpudownload/Pages/index.aspx –  Celso Jan 18 '12 at 11:17
    
Yes, for each GPU I used the driver direct from the vendor. –  Huckle Jan 18 '12 at 19:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.