Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a lenovo y460 laptop with hybrid graphics. it's a nvidia optimus card and a integrated intel graphics.

I'm only using the integrated chip and i don't want use the nvidia card

the problem occur in ubuntu 10.04 and ubuntu 11.10

i can not work when the flickering occur .

that all right in windows 7 so i think it's a driver or kernel problem

i have try the i915.powersave=0 but it's no use

and i915.modeset=1 make the resultion horrible

the only clue is the xorg.0.log,when the flickering occur the xorg.0.log full with :

[  2868.431] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1502  768 771 776 788 -hsync -vsync (47.3 kHz)
[  2873.979] (II) intel(0): Printing DDC gathered Modelines:
[  2873.979] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1502  768 771 776 788 -hsync -vsync (47.3 kHz)
[  2874.479] (II) intel(0): EDID vendor "LGD", prod id 654
[  2874.479] (II) intel(0): Printing DDC gathered Modelines:
[  2874.479] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1502  768 771 776 788 -hsync -vsync (47.3 kHz)
[  2881.539] (II) intel(0): EDID vendor "LGD", prod id 654
[  2881.539] (II) intel(0): Printing DDC gathered Modelines:
[  2881.539] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1502  768 771 776 788 -hsync -vsync (47.3 kHz)
[  2881.539] (II) intel(0): EDID vendor "LGD", prod id 654
[  2881.539] (II) intel(0): Printing DDC gathered Modelines:
[  2881.539] (II) intel(0): Modeline "1366x768"x0.0   71.00  1366 1414 1446 1502  768 771 776 788 -hsync -vsync (47.3 kHz)

i don't know who output the information

and there is another clue when the flickering occur ,i switch to tty1 (crtl+alt+F1) ,i found there some char "^@" output to the screen. even when the os boot i found the char "^@" occur in the screen

update: my problem maybe is a acpi problem so i have try below kernel params:

acpi_osi=Linux acpi_backlight=vendor acpi=copy_dsdt nohz=off highres=off acpi=noirq pcie_aspm=force

you also could try:

 acpi=off nolapic

but it's a nuclear way because it make another problem

share|improve this question
    
^@ is a null byte. Has a key on your keyboard got stuck? –  Lekensteyn Jan 10 '12 at 12:10
    
@Lekensteyn no i have check the keybord. and i found other people have the problem. i guess it's linux don't support my hardware?? –  wliment Jan 11 '12 at 3:21
    
when the char "^@" occur ,the xorg.0.log are full with the information which i have menction above –  wliment Jan 11 '12 at 3:23

2 Answers 2

Try reflashing your BIOS. The ACPI tables that you showed on https://github.com/Bumblebee-Project/bbswitch/issues/7 are incomplete.

The BIOS can be downloaded from http://consumersupport.lenovo.com/sg/en/DriversDownLoads/drivers_show_2612.html

A similar issue: ACPI 30k+ interrupts per second (this time with a Lenovo Y460, but with AMD graphics!)

share|improve this answer
    
i already update my bios before,but no use for this,so it's maybe a hardware problem. –  wliment Jan 19 '12 at 4:34
    
Have you tried applying the same update again? –  Lekensteyn Jan 19 '12 at 10:49
    
i have try the new bios again,but it no effect.if it really is a bios problem , why windows 7 no this error,the bios only supprot the windows ??? –  wliment Jan 20 '12 at 9:33
    
use kernel params nolapic can make this error disapper,but my core i3 multi core became only one. –  wliment Jan 20 '12 at 9:37
    
The option "noacpi" may solve the issue, but it also disables a lot PM functionality like suspend. Maybe Lenocrap is providing drivers which does some houskeeping that should be done by BIOS. –  Lekensteyn Jan 20 '12 at 9:54

I was having the same problem on a Dell Inspiron 15R. Try this, it worked for me!

Open the terminal and run: xinput list

Try to find this entry: ↳ Video Bus id=8 [slave keyboard (3)]

Get the "id" and disable it running: sudo xinput set-pro 8 "Device Enabled" 0

share|improve this answer
    
thanks you. i will try this later. –  wliment Mar 20 '12 at 8:22
    
it's work for me ,thank you!!! –  wliment Apr 25 '12 at 14:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.