Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We have an old ubuntu breezy server which someone unsucessfully has tried to upgrade in the past. We need it upgraded, but almost all apt-get operations return something like this:

apt-get install -f

Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
3 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line >17.
dpkg: dependency problems prevent configuration of apt:
dpkg (1.14.5ubuntu16) breaks apt (<< 0.7.6ubuntu6) and is installed.
Version of apt to be configured is 0.6.43.3ubuntu2.
dpkg: error processing apt (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apt-utils:
apt-utils depends on libapt-pkg-libc6.3-6-3.11; however:
Package libapt-pkg-libc6.3-6-3.11 is not installed.
Package apt which provides libapt-pkg-libc6.3-6-3.11 is not configured yet.
dpkg: error processing apt-utils (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aptitude:
aptitude depends on libapt-pkg-libc6.3-6-3.11; however:
Package libapt-pkg-libc6.3-6-3.11 is not installed.
Package apt which provides libapt-pkg-libc6.3-6-3.11 is not configured yet.
dpkg (1.14.5ubuntu16) breaks aptitude (<< 0.4.6.1-1ubuntu2) and is installed.
Version of aptitude to be configured is 0.4.0-5ubuntu3.
dpkg: error processing aptitude (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
apt
apt-utils
aptitude
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas as to how i can correct this, so we can upgrade one ver. at a time (or up to 10.04)

share|improve this question
    
Ok, apparently lsb_release -a gives me this: -so it's more "out of shape" than i thought. Some of it runs as breezy... LSB Version: n/a Distributor ID: Ubuntu Description: Ubuntu 6.06 LTS Release: 6.06 Codename: dapper –  JaR Jan 10 '12 at 10:17
    
have you tried doing "sudo dpkg --configure -a " –  rao_555 Jan 10 '12 at 10:53
add comment

1 Answer

up vote 0 down vote accepted

It has dpkg 1.14.5ubuntu16 from Gutsy installed and tries to update apt to 0.6.43.3ubuntu2 from Dapper, but this apt version is incompatible with the installed dpkg (and quite likely so is the currently installed version of apt).

If you really want to upgrade change your sources.list to use gutsy (http://old-releases.ubuntu.com/ has it). Then manually download and install apt from Gutsy (and anything it needs) and try to dist-upgrade.

But I would think about a fresh install as a mix of Dapper and Gutsy sounds quite ugly and if there are still some packages from Breezy left that doesn't make it any better.

share|improve this answer
    
Thanks, u r right, but this particular server must be upgraded before a new replacement can be set up in addition to this (don't ask - it's a 'very' custom system) Anyway, that seems to have done the trick. –  JaR Jan 10 '12 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.