Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the Server on a desktop with two network cards. I've installed dnsmasq, squid, shorewall, ssh, and dansguardian.

how do I get this device to talk to DSL modem and my network (through my router)

I've configured the network cards to separate networks. I've set up the DHCP/DNC settings (I did not install dhcp3-server, using dnsmasq).

I've tried following these instructions as guide line. http://taksuyama.com/?p=16

Any help would be great. These are great devices when they work for homes with kids!

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
'These are great devices when they work for homes with kids' -- Yes, and helpful for the occasional grown-up too. –  Smandoli Aug 17 '10 at 20:13

2 Answers 2

You can configure your firewall (shorewall) in such a way that all outgoing packages that represent web traffic, i.e. ports 80, 443 will be forwarded to the same host (127.0.0.1) and the port on which your dansguardian process is listening too. This way there is no direct connection for these ports to the outside anymore, but all are filtered by dansguardian.

share|improve this answer
    
Thanks, I'll look into that. I know I set some of that up. I'll double check it. –  M J Aug 5 '10 at 2:38

If you already have a router hooked up to your DSL modem by way of the router's "internet" port, then this complicates things. Essentially you want to replace that router with a linux router that has the desired capabilities.

So the recommended setup would be

(internet)=----=[dsl modem]=----=[server w/ 2 nics]=-----=[LAN port of router/wifi AP/etc]---> all of your computers

Doing it this way should make the linked HOWTO work. You'll need to disable DHCP and UPnP on the router too, as that may interfere with your Linux's server's functioning.

share|improve this answer
    
That's exactly what I've done. The first problem I'm having is the Linux box talking to the modem. I've disabled the dhcp on the router and the PPPOE. I can't get pppoeconf to talk negotate a connection –  M J Aug 9 '10 at 13:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.