Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP dv6, specifically with a ati radeon hd 5650. It's one of those wonderful hybrid graphics cards.

I've spent a great amount of time trying to install the drivers for this graphics card properly. My primary reason to do this is to run gnome 3, which will not work properly when I install the fglrx driver from the additional drivers section of system settings. I know the desire to run gnome 3 might sound trivial, but I've made it my mission to get this to work. Is there a way to simply ignore the ati graphics and go with the intel graphics when using gnome?

So, after reinstalling ubuntu using wubi, I immediately followed this guide.

However, I ran into some blocks. When I ran the aticonfig command, I got a response

PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory

I setup a symbolic link between /usr/lib and /usr/lib64. I do not know if that is correct, but it got my forward. When I rebooted the computer after calling aticonfig, I ended up hanging while booting on a black screen. It was like

Checking Blah            [ok]
.....
Checking Battery State   [ok]

There were some fails, but the ones I could see were not important. So i go into tty1 and trying running the command fglrxinfo, but i receive the response:

Error: unable to open display (null)

So, I look at my Xorg.conf file, and the contents, which seem strange, are as follows:

Section "ServerLayout"
    Identifier   "aticonfig Layout"
    Screen     0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option       "VendorName" "Ati Proprietary Driver"
    Option       "ModelName" "Generic Autodetecting Monitor"
    Option       "DPMS" "true"
EndSection


Section "device"
    Identifier   "aticonfig-Device[0]-0"
    Driver       "fglrx"
    BusID        "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier   "aticonfig-Screen[0]-0"
    Device       "aticonfig-Device[0]-0"
    Monitor      "aticonfig-Monitor[0]-0"
    DefaultDepth    24
    Subsection "Display"
        Viewport  0 0
        Depth  24
    EndSubsection
Section

I tried doing aticonfig --acpi-services=off as well as other threads state, but that did not work.

I'd really appreciate any help that I can get.

Thanks.

EDIT

I found out that if I remove my xorg.conf file, I can at least boot and login into ubuntu's gui

share|improve this question

2 Answers 2

This is how I got it to work on my Intel/AMD hybrid setup:

  • Update X.org to latest version by adding the following PPA:

    sudo apt-add-repository ppa:xorg-edgers/ppa
    sudo apt-get update && sudo apt-get dist-upgrade
    
  • Symbollically Link lib & lib64 to avoid lib64 error:

    sudo ln -s /usr/lib/ /usr/lib64/
    
  • Install ATI Driver Manually DO NOT build deb packages:

    sudo sh ./amd-driver-installer-12-1-x86.x86_64.run
    
  • Update X.org:

    sudo aticonfig --initial --nobackup
    
  • After that, reboot your computer.

share|improve this answer
1  
where can i download amd-driver-installer-12-1-x86.x86_64.run? –  Zoltán Jan 13 '13 at 13:05

I was stuck with the same problem, in Ubuntu Precise x64 (Linux Mint Maya actually). Blank screen, nothing else. I had to enter the login password and after a the system loaded, pressing Alt-F1 opened at least the new terminal session. Since the internet connection was not working (it's KDE, uses wallet to store passwords, though you could theoretically introduce blindly its password as with the user login), instead of installing the last xorg (as per Octavian) y just made the symbolic link:

sudo ln -s /usr/lib32/ /usr/lib/

And reboot. And it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.