Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use the Windmill Testing Framework over https. When I run windmill firefox the Windmill IDE comes up fine. When I run windmill firefox the IDE fails. (I have installed pyopenssl in my Python virtual environment. https failed completely before I did this.)

I suspect that this is because I haven't installed the Certificate Authority (.crt file) for Windmill itself.

The Windmill team provide instructions for installing the Windmill CA on Windows and Mac, but not Linux, let alone Ubuntu :(

The instructions on and How do I install a root certificate? suggest that I need both a .crt file and a .key file, but only a .crt file is provided, and seems to be all that is needed on other OSes.

How can I install the provided .crt file? (Or, what is the Ubuntu equivalent of the provided Windows/Mac instructions?)

share|improve this question
up vote 1 down vote accepted

The .crt file is already installed in the Firefox profile created by Windmill. No additional steps are required.

You can verify this by running Firefox through Windmill, then opening Edit (menu) | Preferences (menu option) | Advanced (tab) | Encryption (tab) | View Certificates (button) | Authorities (tab), and scrolling down the list to confirm Windmill is listed.

If for some reason it isn't (due to a bug) you could try adding it manually. In general Linux/Ubuntu applications don't use a central resource for certificate authorities, so you can follow the directions above and click the Import... button. The Windmill CA instructions include links to the latest .crt file.

This hasn't actually solved my problem, but eliminates this as the cause and answers the question.

share|improve this answer
my original problem was because I was running windmill firefox instead of windmill firefox ssl – d3vid Jan 23 '12 at 9:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.