Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried the command

sudo s2disk 

but the OS said command not found so I went and installed

sudo apt-get install uswsusp

now the command worked, and the computer did hibernate, but it failed to resume.

I also installed


hoping that hibernate would show up in the menu, but it didn't. (I did press the Alt key)

share|improve this question

migrated from Jan 10 '12 at 3:17

This question came from our site for system and network administrators.

there should ba button called hibernate – VENKI Jan 10 '12 at 3:45
do you have a swap partition? – kernel_panic Jan 10 '12 at 8:03
OP did you find an answer? if yes, please consider posting it here. – Mahesh Apr 14 '12 at 9:56
up vote 1 down vote accepted

in case you have any graphics card in your system make sure your currently installed driver has no hibernate/suspend issues.

I had similar issue of machine failing to resume, installing the latest graphics driver (catalyst 11.12 in my case) fixed it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.