Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using latest ubuntu. My language changed to chinese somehow. Everything comes in chinese and I couldn't get it back to english. Tried changing in language support, but english is written in chinese which I don't understand :(

Is there a way to change back to english using terminal and not gui way?

share|improve this question

migrated from stackoverflow.com Jan 8 '12 at 20:53

This question came from our site for professional and enthusiast programmers.

4  
English in Chinese is 英語 (Traditional) and 英语 (Simplefied), hopefully that way you can recognize it in the GUI. – titaniumtux Jan 8 '12 at 21:10

Solved the Language issue by a logical way.

Today my Ubuntu 10.04 shows menus and sub-menus in Chinese (中文) Language. Even Terminal too.

  1. I used trial and error method. Finally Solved my issue.
  2. I took Keyboard Layout settings from Panel.
  3. A pop-up window appeared. But I couldn’t read there anything in Languages menu. Because Chinese Language was there.
  4. I took English to Chinese in Google search. Typed English (United States) In the box for Enlish and google converted it to 英语(美国)
  5. Searched the letters in my Languages menu and i found it. (There was a heading, 'Change will be applied next time you login'- "Yes, remember it")
  6. Again I took the next menu in Keyboard layout named Formats, changed the format to 英语(美国); this means English (United states) - "Thanks, google". (If we cannot see the 英语(美国) English (United states), You click on the "+" button in the bottom and select which you want from there
  7. Just closed the pop-up window and System Rebooted. All menus and Sub-menus Smiled with English(US) language. Solved my issue!!!
share|improve this answer

The ~/.pam_environment file was the source of my problem. In /etc/default/locale and ~/.pam_environment

I edited the second file here to have:

LANGUAGE=en_US.UTF-8:en
LANG=en_US.UTF-8

(for US users). You will probably see other entries in .pam_environment that are correct, so you can cut and paste these into the above two variables. Note the ending ":en" for the LANGUAGE variable which appears to be unique for that variable.

From sacadough on the thread:

share|improve this answer
    
This is a much better answer than @adamoxford because it allows you to fix the problem without having to try to figure out Chome's settings page that, because of the bug, is in Chinese! Thanks a ton!!! – Garrett Fogerlie Sep 7 '13 at 15:25

Exactly the same thing happened to me just now.

English in Chinese is 英語 (Traditional) and 英语 (Simplefied) (thanks - and copied from comment from @titaniumtux)

I was able to change it back using the keyboard layout options in Settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.