Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Previously I asked about the same problem in Ubuntu 11.04 with messed up drivers, but now I completely reinstalled system and updated it to latest 11.10.

Last time, I tried using various drivers for discrete video adapter, and thus messed up whole driver system and X server. As was proposed in answer to my previous question, I installed all anew, and of course, I did not install any drivers for any cards.

Ubuntu 11.10 starts okay, with Integrated card on, like 11.04 did. Vgaswitcheroo has the same problems, though: it switches off discrete card power okay, but does not make it work as main card (by echoing DIS to it). And echoing DDIS to it, and then restarting X server results in black screen with some console lines in it, or in completely black screen.

I did not install fglrx, ati driver or any third-party software to manipulate gpu states, because I am afraid of doing something more complicated again. So, my question is following: what else can I try to do to make the radeon work? What software could help? Is there a way to completely switch off Intel card and reinstall Ubuntu this way, so it would regard Radeon as single card without any hybrid modes?

Thanks in advance!

share|improve this question

1 Answer 1

I have the same laptop with hybrid Intel HD3000 and RadeonHD 6650 GPUs. I suspect you have probably found a workable solution in the 6 months since you posted this question, but just in case you haven't (and assuming you aren't vehemently opposed to the proprietary drivers released by AMD), the information in the following two links is extremely helpful and has worked very well on my G770.

NOTE: From my experience, these AMD Catalyst drivers work very well when installed on kernel 3.2.0-26 or earlier; I have had and am currently attempting to work through some suspend/resume issues under 3.2.0-27 (in Unity3D -- Unity2D, Gnome-Shell, and all other DE's work flawlessly). Additionally, any time you upgrade to a new kernel version you will need to uninstall and reinstall the drivers, as the Catalyst installer creates packages specifically for the running kernel it detects. If you are running kernel 3.5, you will need to install Catalyst 12.6 rather than 12.4, which is as simple as replacing all instances of "12.4" with "12.6" when following the instructions in the first link.

Simple Step-By-Step Driver Installation Instructions
http://ubuntuforums.org/printthread.php?s=c2d469eb5a578eb0871a2dfba23a0b8c&t=1930450&pp=75

Simple Method of Driver Removal (answer #2, by bioShark)
What Packages/How Do I Uninstall Propriety AMD Catalyst Driver

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.