Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm relatively new to Ubuntu(installed 11.10 just 2 days ago).

The thing is that if I connect my zte mf691 modem via usb it shows up in connection manager. If I connect to the internet with the modem it gets connected but webpages do not load. In windows I used to set an extra initialisation for the modem to connect to my Ip's network {AT+CGDCONT=1,"IP","AIRCELGPRS"}.

How do I set it in Ubuntu? A brief explanation or even a link would be sufficient.

share|improve this question

2 Answers 2

I configured a ZTE USB modem in Ubuntu while in Mali, but it was exactly like the Huawei ETS2055 (it's on MaliTel's CDMA towers), except for having a different Vendor ID/Product ID. I found your device on a forum thread, but I'll try to give you steps to get roughly any USB modem working in Ubuntu using your modem as an example:

  • Execute lsusb in the terminal to find out your modem's Vendor ID/Product ID. That forum thread indicated it's 19d2:1201 (if your device shows up with a different VID/PID, you must use the one you see in lsusb to set up your modem)

  • Make sure you have usb-modeswitch installed. If it's not installed, in terminal run

    sudo apt-get install usb-modeswitch
    

    or Using software center Install via the software center

    You may also need wvdial installed, in that case in terminal run

    sudo apt-get install wvdial
    

    Or using software center Install via the software center

  • As far as I know, your device is not identified by USB Modeswitch by default. Let's start by adding it to the startup modules. Run gksudo gedit /etc/modules and add usbserial vendor=0x19d2 product=0×1201 to the end of the file

  • Let's add your modem to USB Modeswitch. Run gksudo gedit /etc/usb_modeswitch.d/19d2:1201 and add the following text (afterwards save and close):

     #### # t-mobile ZTE MF691  Rocket 2
    
     DefaultVendor= 0x19d2
     DefaultProduct= 0x1201
    
     TargetVendor= 0x19d2
    
     TargetProduct= 0x1201
    
     CheckSuccess=20
    
     MessageContent= "5553424392020000000000000000061B000000020000000000000000000000"
    
     #### # end
    
  • I recommend rebooting at this point. Next run this command in terminal to get your device detected immediately: sudo usb_modeswitch -H -c 19d2:1201

  • If your device uses a username, password and dial number for authentication, you'll have to do these steps in wvdial. In terminal run sudo wvdialconf
  • Now edit the generated configuration file to input your authentication info by executing gksudo gedit /etc/wvdial.conf (add your username, password and dial number and don't forget to remove the semi-colons in order to uncomment them!!)
  • Now do this graphically: Network Manager>Edit Connections..., then Mobile Broadband>Add, and add your modem. Once added, go to Edit to input your user name, password and dial number for authentication). Afterwards you should be able to connect from the Network Manager.
  • Also, always boot with the modem connected. Otherwise you may have to run the modprobe command again (that's sudo usb_modeswitch -H -c 19d2:1201

These instructions are based on past experience with the CDMA modems I configured in Mali, which I documented on my personal wiki.

share|improve this answer
    
I tried installing wvdial but it hangs for more than 30min at "Setting up wvdial (1.61-4) ... "... any help???? –  Bharath Jan 9 '12 at 16:47
    
Is wvdial successfully installed? If so, does it detect your modem? –  titaniumtux Jan 10 '12 at 1:18

The easiest way to select the network which you need from the 3rd party software's settings( Hybrid, 1x,etc are the words in the software to mention 2g and 3g). After the service selected, you could see the led on the modem changes its color. After the selection you can continue using Network Manager or wvdial. (I used zte2737 and there was an installation file for linux)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.