Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

11.04 64bit and there is a problem with Firefox. Firefox doesn't display texts in websites for example in it doesn't show any text (for example there is mail Javabutton but it doesn't have text on it!) and when i click on Javabuttons nothing happen!! even it doesn't show news texts on this site. and there is same problem in other sites. i removed Firefox completely and install it again but it didn't fix. please help me!

enter image description here

share|improve this question
What version of firefox, what version of Ubuntu, and what firefox extensions or customizations do you have ? My guess would be a corrupt extension. Disable all your extensions and re-enable them one at a time. If the fails, try starting firefox with a fresh profile firefox -P – bodhi.zazen Jan 8 '12 at 17:24
i am using ubuntu 11.04 and it is firefox 9.0. i tried what you said and it didn't fix. – hossein hosseinvand Jan 8 '12 at 19:42
Are you using a custom Unity theme ? – bodhi.zazen Jan 8 '12 at 19:47
i put image of my browser. – hossein hosseinvand Jan 8 '12 at 19:52
Try changing back to the default theme (I wonder if it is theme related). – bodhi.zazen Jan 8 '12 at 19:58

I had the same problem after fresh install of Ubuntu 11.10. The problem was solved after I deleted my custom fonts.

I keep my fonts in "/user/share/fonts/truetype/fonts from web". When I copied my "old" fonts into this "fonts from web" folder, Firefox went blank. Took me about two days though to realise the problem. As soon as I deleted custom folder, Firefox is back. Some of the old font must have been coliding. Have to investigate more.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.