Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu and I like it.

I have some issues with the window movement performance (in Unity). My PC has a AMD Phenom X4 955 processor, 4 GB ram and AMD HD 6950 graphics card.

So its not that slow, but the windows (Nautilus, Firefox - just about any window really) move very sluggishly. I tried it with the AMD driver that Ubuntu provides (FGLRX driver, the standard, not the newest) and without it. I have installed Compiz Config and disabled the vsync, and also tried to switch vsync in the catalyst drivers on and off. Nothing seems to work.

Sometimes the window movement is perfectly smooth for a moment, then it gets slow as hell again. the other effects like minimizing are working very smooth. Any ideas what to do? It's really annoying.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You should install the latest drivers for your card, they give so much better support than the ones included on the Ubuntu repos.

If you need any help to install the ATI drivers on your system have a look at this question Is my ATI graphics card supported in Ubuntu? It will help you download and install the latest drivers in your system.

The included drivers (fglrx 11.08 and fglrx 11.09) in the Ubuntu repos are not really the best ones to fully appreciate Unity, only after the upgrade to fglrx 11.11 had I a good experience with it, no more slowness and hanging windows and movies. All worked much, much better.

The guide I included will install fglrx 11.12, they are the current latest drivers from ATI.

share|improve this answer
    
Thanks, the installation went fine. The windows movement is way better now. Huge improvement. Thanks alot! :D Most of the time the movement is almost smooth, but sometimes it still laggs a bit. Any further advice? :) –  Nekomancer Jan 8 '12 at 15:21
    
No, unless you want to go back to the opensource ones, they where the ones that worked best till now, but they are not good enough to use for multimedia and games. Its an ATI thing, not much we can do with them, I would at least expect that they keep the good work on the drivers that they did till now. –  Bruno Pereira Jan 8 '12 at 15:23
    
Hm, okay. I also noticed just now: when i click on the dash-start icon (not shure how to call it) the window does not imediatly open like before, it now takes about 2 seconds, and in that time the flashvideo that i watch in the background freezes. any ideas on why? also: i read its good to disable the vsync in Compiz config, but it seems its on every time i restart the pc. any way to make the setting permanent? –  Nekomancer Jan 8 '12 at 15:27
    
try Option "EXAVSync" "yes" in your xorg.conf file, it helps me a bit. Also Option "AccelMethod" "EXA" should work better on newer cards, if you cant boot with any of these options remove them and reboot. –  Bruno Pereira Jan 8 '12 at 15:43
    
What "Section" would that go in? –  Nekomancer Jan 8 '12 at 16:43
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.