Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a new PCI Gigabit Ethernet card, yet it is not working well. It works for a few minutes then suddenly stops running. I found logs in /var/log/syslog saying irq 18: nobody cared (try booting with the "irqpoll" option) and tried the option. Now it takes several hours before the network interface goes down. Running ifdown eth0 && ifup eth0 makes it up again, but it does not look like a permanent solution.

Below is information that I think seems relevant to this issue:

/var/log/syslog

Jan  6 06:21:51 ubuntu kernel: [  436.677602] irq 18: nobody cared (try booting with the "irqpoll" option)
Jan  6 06:21:51 ubuntu kernel: [  436.677662] Pid: 0, comm: swapper Tainted: G         C  3.0.0-14-generic-pae #23-Ubuntu
Jan  6 06:21:51 ubuntu kernel: [  436.677665] Call Trace:
Jan  6 06:21:51 ubuntu kernel: [  436.677672]  [<c1542c41>] ? printk+0x2d/0x2f
Jan  6 06:21:51 ubuntu kernel: [  436.677680]  [<c10b3e59>] __report_bad_irq+0x29/0xd0
Jan  6 06:21:51 ubuntu kernel: [  436.677691]  [<f844c5ae>] ? rtl8169_interrupt+0xbe/0x210 [r8169]
Jan  6 06:21:51 ubuntu kernel: [  436.677696]  [<c10b4224>] note_interrupt+0x104/0x150
Jan  6 06:21:51 ubuntu kernel: [  436.677701]  [<c10b274e>] handle_irq_event_percpu+0x9e/0x200
Jan  6 06:21:51 ubuntu kernel: [  436.677706]  [<c1026ae0>] ? msi_set_affinity+0x60/0x70
Jan  6 06:21:51 ubuntu kernel: [  436.677710]  [<c12bef7f>] ? msi_set_mask_bit+0x6f/0x80
Jan  6 06:21:51 ubuntu kernel: [  436.677714]  [<c10b28eb>] handle_irq_event+0x3b/0x60
Jan  6 06:21:51 ubuntu kernel: [  436.677719]  [<c10b4960>] ? unmask_irq+0x30/0x30
Jan  6 06:21:51 ubuntu kernel: [  436.677723]  [<c10b49ae>] handle_fasteoi_irq+0x4e/0xc0
Jan  6 06:21:51 ubuntu kernel: [  436.677725]  <IRQ>  [<c155e352>] ? do_IRQ+0x42/0xc0
Jan  6 06:21:51 ubuntu kernel: [  436.677734]  [<c1057360>] ? irq_exit+0x60/0xa0
Jan  6 06:21:51 ubuntu kernel: [  436.677737]  [<c155e429>] ? smp_apic_timer_interrupt+0x59/0x88
Jan  6 06:21:51 ubuntu kernel: [  436.677741]  [<c155e1b0>] ? common_interrupt+0x30/0x38
Jan  6 06:21:51 ubuntu kernel: [  436.677747]  [<c105007b>] ? default_handler+0x2b/0x70
Jan  6 06:21:51 ubuntu kernel: [  436.677752]  [<c12e25e7>] ? intel_idle+0xb7/0x110
Jan  6 06:21:51 ubuntu kernel: [  436.677758]  [<c14397dd>] ? cpuidle_idle_call+0x7d/0x240
Jan  6 06:21:51 ubuntu kernel: [  436.677762]  [<c1008c7a>] ? cpu_idle+0x8a/0xc0
Jan  6 06:21:51 ubuntu kernel: [  436.677767]  [<c1527355>] ? rest_init+0x5d/0x68
Jan  6 06:21:51 ubuntu kernel: [  436.677773]  [<c17fa774>] ? start_kernel+0x352/0x358
Jan  6 06:21:51 ubuntu kernel: [  436.677777]  [<c17fa3b3>] ? pass_bootoption.constprop.2+0xe2/0xe2
Jan  6 06:21:51 ubuntu kernel: [  436.677782]  [<c17fa0ba>] ? i386_start_kernel+0xa9/0xaf
Jan  6 06:21:51 ubuntu kernel: [  436.677784] handlers:
Jan  6 06:21:51 ubuntu kernel: [  436.677808] [<f844c4f0>] rtl8169_interrupt
Jan  6 06:21:51 ubuntu kernel: [  436.677846] Disabling IRQ #18
Jan  6 06:25:53 ubuntu kernel: [  678.228016] ------------[ cut here ]------------
Jan  6 06:25:53 ubuntu kernel: [  678.228027] WARNING: at /build/buildd/linux-3.0.0/net/sched/sch_generic.c:255 dev_watchdog+0x1e6/0x1f0()
Jan  6 06:25:53 ubuntu kernel: [  678.228031] Hardware name: MS-7680
Jan  6 06:25:53 ubuntu kernel: [  678.228033] NETDEV WATCHDOG: eth0 (r8169): transmit queue 0 timed out
Jan  6 06:25:53 ubuntu kernel: [  678.228035] Modules linked in: snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd i915 drm_kms_helper drm i2c_algo_bit mei(C) video coretemp soundcore snd_page_alloc shpchp psmouse serio_raw rt3070sta lp parport usb_storage uas r8169 ahci libahci
Jan  6 06:25:53 ubuntu kernel: [  678.228065] Pid: 0, comm: swapper Tainted: G         C  3.0.0-14-generic-pae #23-Ubuntu
Jan  6 06:25:53 ubuntu kernel: [  678.228068] Call Trace:
Jan  6 06:25:53 ubuntu kernel: [  678.228075]  [<c1050462>] warn_slowpath_common+0x72/0xa0
Jan  6 06:25:53 ubuntu kernel: [  678.228080]  [<c147a286>] ? dev_watchdog+0x1e6/0x1f0
Jan  6 06:25:53 ubuntu kernel: [  678.228083]  [<c147a286>] ? dev_watchdog+0x1e6/0x1f0
Jan  6 06:25:53 ubuntu kernel: [  678.228088]  [<c1050533>] warn_slowpath_fmt+0x33/0x40
Jan  6 06:25:53 ubuntu kernel: [  678.228092]  [<c147a286>] dev_watchdog+0x1e6/0x1f0
Jan  6 06:25:53 ubuntu kernel: [  678.228098]  [<c105d8af>] call_timer_fn+0x2f/0x110
Jan  6 06:25:53 ubuntu kernel: [  678.228102]  [<c147a0a0>] ? qdisc_reset+0x40/0x40
Jan  6 06:25:53 ubuntu kernel: [  678.228106]  [<c105efab>] run_timer_softirq+0xeb/0x210
Jan  6 06:25:53 ubuntu kernel: [  678.228109]  [<c147a0a0>] ? qdisc_reset+0x40/0x40
Jan  6 06:25:53 ubuntu kernel: [  678.228114]  [<c1056fb0>] ? local_bh_enable_ip+0x90/0x90
Jan  6 06:25:53 ubuntu kernel: [  678.228118]  [<c1057031>] __do_softirq+0x81/0x1a0
Jan  6 06:25:53 ubuntu kernel: [  678.228122]  [<c1056fb0>] ? local_bh_enable_ip+0x90/0x90
Jan  6 06:25:53 ubuntu kernel: [  678.228125]  <IRQ>  [<c1057376>] ? irq_exit+0x76/0xa0
Jan  6 06:25:53 ubuntu kernel: [  678.228132]  [<c155e429>] ? smp_apic_timer_interrupt+0x59/0x88
Jan  6 06:25:53 ubuntu kernel: [  678.228137]  [<c1557299>] ? apic_timer_interrupt+0x31/0x38
Jan  6 06:25:53 ubuntu kernel: [  678.228141]  [<c105007b>] ? default_handler+0x2b/0x70
Jan  6 06:25:53 ubuntu kernel: [  678.228147]  [<c12e25e7>] ? intel_idle+0xb7/0x110
Jan  6 06:25:53 ubuntu kernel: [  678.228153]  [<c14397dd>] ? cpuidle_idle_call+0x7d/0x240
Jan  6 06:25:53 ubuntu kernel: [  678.228157]  [<c1008c7a>] ? cpu_idle+0x8a/0xc0
Jan  6 06:25:53 ubuntu kernel: [  678.228163]  [<c1527355>] ? rest_init+0x5d/0x68
Jan  6 06:25:53 ubuntu kernel: [  678.228169]  [<c17fa774>] ? start_kernel+0x352/0x358
Jan  6 06:25:53 ubuntu kernel: [  678.228173]  [<c17fa3b3>] ? pass_bootoption.constprop.2+0xe2/0xe2
Jan  6 06:25:53 ubuntu kernel: [  678.228177]  [<c17fa0ba>] ? i386_start_kernel+0xa9/0xaf
Jan  6 06:25:53 ubuntu kernel: [  678.228180] ---[ end trace 582a116d2bf2b697 ]---
Jan  6 06:25:53 ubuntu kernel: [  678.244049] r8169 0000:03:00.0: eth0: link up

System

  • CPU: Intel Celeron G530
  • Motherboard: MSI H61M-E23 (B3)
  • RAM: Samsung DDR3-1333 2x4GB
  • HDD: WD Caviar Blue WD10EALX 1TB
  • TP-Link TG-3269 PCI Gigabit Ethernet card
  • OS: Ubuntu 11.10

The onboard LAN (eth1) is working without any problem.

share|improve this question

closed as off topic by qbi, Ringtail, jrg Apr 6 '12 at 20:52

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Mar 27 '12 at 20:13
    
It seems you triggered a bug. So I would suggest writing a bug report. see askubuntu.com/q/5121/236 for hints. –  qbi Apr 6 '12 at 12:38
add comment

1 Answer 1

up vote 1 down vote accepted

It seems you hit a bug here. Please see Bug 38632 - IRQ Nobody Cared on Sandybridge Additional Ethernet Card. This seems the same kind of bug you encountered.

Askubuntu can not do anything useful for you in this case. I advise to follow the bug report, maybe add some more information and wait until it is fixed.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.