Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have a Toshiba C650 laptop for a year and i had some problems with corrupted clusters in a partition and i tried to fix it by running chkdsk and change partitions which resulted into a not bootable laptop to windows 7. That made me decide to install ubuntu (an excuse) but still after many installs i get always a no bootable devices found during start up. The installation is flawless but no boot what so ever... I tried to fix the grub with boot-repair but nothing.

How can i see what is wrong? I suspect that the MBR is completely corrupt, is it true? Please help i don't know what to do :(

Thanks

share|improve this question
add comment

1 Answer 1

Did you install Ubuntu? My Laptop never works with the 'desktop' installer (the preview livecd) but always works with the 'alternative' installer. It has the same symptoms, grub simply won't work and no attempt at recovering it succeeds. Try that and see if that works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.